Results 1 to 13 of 13
  1. #1
    Lounger
    Join Date
    Feb 2001
    Location
    Orlando, FL
    Posts
    44
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Attaching templates

    We are in the process of converting from WordPerfect to Word 2000. When the docs are converted, the numbering of course is all messed up. I have created a template that uses the Heading styles for the outline numbering I need. When I attempt to attach the template to a converted document, the heading styles come in but the numbered levels are not linked to the correct Heading style. This is in the "Customize Outline Numbered List" dialog box found under "Bullets and Numbering" or within the each style. The styles are linked correctly in the template but for some reason this does not carry over. Any help would be appreciated.

    Thank you.

    Larry

  2. #2
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts

    Re: Attaching templates

    Larry

    Have a look at this macro and see if it helps. <A target="_blank" HREF=http://www.wopr.com/cgi-bin/w3t/showflat.pl?Cat=&Board=wrd&Number=25250&page=0&vie w=expanded&sb=5#Post25250>Related post</A>

    It may just be local formatting that can be removed with a Ctrl-Space and Ctrl-Q.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  3. #3
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Re: Attaching templates

    Just to ask the obvious, when you attach the template, are you putting a checkmark next to "Automatically update document styles"? - without this checkmark on, you won't be "downloading" the template's style definitions to the document.

    P.S. And always be sure to go back into the Templates and Add-Ins dialog and Uncheck this checkmark, after using it.

  4. #4
    Lounger
    Join Date
    Feb 2001
    Location
    Orlando, FL
    Posts
    44
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Attaching templates

    I have tried it with the "Automatically Update" option checked and unchecked. Neither works. As a side note, when I "Copy" the styles through the Organizer they come through perfectly.

  5. #5
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Attaching templates

    Hi lland:

    This is a bug in Word 2000. See
    <A target="_blank" HREF=http://support.microsoft.com/support/kb/articles/Q211/5/56.ASP>http://support.microsoft.com/support/kb/ar...s/Q211/5/56.ASP</A>

    Normally, you can copy a template's styles to a document in 3 ways:
    1. By using Tools/Templates & add-ins/Automatically Updater Document Styles
    2. By manually copying styles to the document using the Organizer.
    3. Change the Applied Style throught Format/Style/Modify/& tick Automatically Update.

    However, if:
    1. You create a document that is based on a template other than your current Normal template,
    2. the Automatically Update Document Styles check box is selected, and
    3. you attach the document to the Normal template,

    the normal.dot styles are not automatically copied. You must use one of the other methods to copy the styles.

    NOTE: This problem does not occur if you attach the document to any template other than Normal.dot. This problem also does not occur if you attach a document that is based on Normal.dot to any other template. This problem occurs because Word retains the styles from the previous template and doesn't make the styles from the Normal.dot template available.

    Hope this helps.

  6. #6
    Lounger
    Join Date
    Feb 2001
    Location
    Orlando, FL
    Posts
    44
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Attaching templates

    Thanks Phil,

    I had read about this problem and I am not sure if this is the same problem or not. This particular document was created in WP7 and converted to Word 2000 and in the process had the Normal template attached to it. I tried to attach a template that I created that has the correct Outline Numbering and this is when the problem occurred.

    I posted this to another forum and someone suggested the following as a potential problem. My Body Text style came in ok as did my Heading 1 (first numbering level in my list template). However, Heading 2 to Heading 9 did not come in correctly. Now, I based Heading 1 on a default style (other than Normal) and then based Heading 2...9 on Heading 1. It was suggested that Word has a hard time bringing in Heading styles that are based on other Heading styles. I disconnected Heading 2..9 from Heading 1 and based them on the default style. As soon as I did this everything came in perfectly. Not sure why, but it is a bug.

    Thanks for your help.

    Larry

  7. #7
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,048
    Thanks
    124
    Thanked 119 Times in 116 Posts

    Re: Attaching templates

    One problem that comes up in copying styles that are based on other styles is that:
    Style C is based on Style B based on Style A based on Style D.

    When the styles are updated Styles are copied in order, Style A, Style B, Style C, and Style D. When the copy of Style A shows up, Style D either doesn't exist or is very different from Style D as it should be. The links get messed up. (This is my theory, not from anyplace else or any authority.)

    I've found that repeating the process (total of three times) greatly improves the transfers. (Same is true of toolbars.) This is based on my experience in Word 97 and Word 2000.

    Perhaps attaching / updating to the same template several times would bring about a like effect. Please let me know.
    Charles Kyle Kenyon
    Madison, Wisconsin

  8. #8
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Attaching templates

    Hi Charles:

    <hr>When the styles are updated Styles are copied in order, Style A, Style B, Style C, and Style D. When the copy of Style A shows up, Style D either doesn't exist or is very different from Style D as it should be. The links get messed up. (This is my theory, not from anyplace else or any authority.)<hr>

    Hate to see an attorney without any authority. Now you're ready for trial. <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

    <A target="_blank" HREF=http://support.microsoft.com/support/kb/articles/Q113/1/06.asp>WD: Styles Copied Using Organizer Lose "Based-on" Setting</A>

  9. #9
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,048
    Thanks
    124
    Thanked 119 Times in 116 Posts

    Re: Attaching templates

    Thanks Phil! <img src=/S/bow.gif border=0 alt=bow width=15 height=15>

    I've updated my page <A target="_blank" HREF=http://www.addbalance.com/usersguide/styles.htm>Understanding Styles</A> (www.addbalance.com/usersguide/styles.htm) to reflect this knowledge base article. You're right, feels much better!
    Charles Kyle Kenyon
    Madison, Wisconsin

  10. #10
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Attaching templates

    The new alphabet according to Microsoft:

    "Word correctly copies style A to the destination and retains the Based On setting. This happens if you copied style B before style A. (If you copied both styles in the same Copy operation, style B occurs alphabetically first, so Word copies it first.)"

    No wonder this software doesn't always work as expected.

  11. #11
    Platinum Lounger
    Join Date
    Feb 2001
    Location
    Yilgarn region of Toronto, Ontario
    Posts
    5,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Attaching templates

    <pre>style B occurs alphabetically first, so Word copies it first
    =============================
    </pre>



    What does your attorney say about that?

    Notwithstanding, I enjoyed the article and I'm glad Charles has added it to his site.

  12. #12
    Platinum Lounger
    Join Date
    Feb 2001
    Location
    Yilgarn region of Toronto, Ontario
    Posts
    5,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Attaching templates

    It's a uBg!

  13. #13
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Attaching templates

    >What does your attorney say about that?<

    I have the right to remain silent <img src=/S/smile.gif border=0 alt=smile width=15 height=15>. (Many people wish I exercised this right.) <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •