Does anyone know of a 3rd party utility to detect if an MDB file requires Access 97 or 2000 and launch the correct version? I saw such a utility once, but I lost the URL for it. I wrote one myself, but every time I switch Access versions, it changes the MDB file association away from my program back to Access.