Results 1 to 5 of 5
  1. #1
    3 Star Lounger
    Join Date
    Apr 2002
    Location
    Redditch, Worcestershire, England
    Posts
    233
    Thanks
    0
    Thanked 22 Times in 21 Posts

    Robust MDAC version? (Access 2000 SR1)

    Hi, I need to install a service pack which lists MDAC2.6 as a minimum pre-requisite, and currently I am on MDAC2.5.

    My home (test) environment is Win 98SE with Access 2000 SR1; my work environment (not under my control!) is Win 2000 SP1, same version of Access.

    Is MDAC 2.6 known to cause any problems in either of these environments? Would any of my code fail if compiled in one environment (with MDAC2.6 applied) and then transferred to the other (still on 2.5)?

    What are the current views on MDAC2.7 - ISTR reading a post a while back that suggested 2.7 was still a bit "flaky"?!

    Thanks for suggestions.

    Jeremy

  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Robust MDAC version? (Access 2000 SR1)

    I haven't had any problems with 2.7 but I haven't been using it much lately. If you install 2.6, do it on ALL machines. Otherwise, if you create a database on a machine with 2.6 and copy it to a machine with 2.5 only, you'll have a problem with the references and get some odd behavior. I've seen these on my own machine when the version I had installed was one behind the version installed on the machine that created the file.
    Charlotte

  3. #3
    3 Star Lounger
    Join Date
    Apr 2002
    Location
    Redditch, Worcestershire, England
    Posts
    233
    Thanks
    0
    Thanked 22 Times in 21 Posts

    Re: Robust MDAC version? (Access 2000 SR1)

    Thanks, Charlotte.

    In terms of references, am I correct in thinking that I will never see an explicit reference to MDAC in a project, but having a particular version of it corresponds to having certain versions of ADO, DAO etc, and these are the actual references that I need to watch?

    Jeremy

  4. #4
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Robust MDAC version? (Access 2000 SR1)

    MDAC installs the ADO libraries, so you won't see a reference to MDAC, only to ADO, ADOX, etc.
    Charlotte

  5. #5
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Robust MDAC version? (Access 2000 SR1)

    2.7 has been refreshed, so old posts might not apply. We needed it to fix a problem with setting up DSNs to SQL Server (my memory is fuzzy on whether we really needed 2.7 or just something higher than 2.5). No problems that I know of since installing in December.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •