Results 1 to 3 of 3
  1. #1
    Star Lounger
    Join Date
    Apr 2002
    Location
    Boise, Idaho, USA
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts

    SQL behind form (Access 2002)

    I'm stymied. I have a form that's requesting data from my table. If I create the form with a query and use the year as the criteria it pulls all the records with that year. In my form I'm using a field that stores the year and when it runs I only get 3 records. If I create a query using the field instead of the actual year, I still only get 3 records. If I change the criteria from the field to the actual year I get all the records. I can't figure out why I don't get all the records I'm asking for and I really don't understand why I can get 3 records and not the rest. I've looked at the records and there doesn't appear to be a difference in the ones that are pulled and the ones that are not.

    Any ideas would be greatly appreciated.

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: SQL behind form (Access 2002)

    Can you post the SQL of the queries? Open a query in design view, then select View/SQL. You can copy the text using Ctrl+C, then paste it into a reply.

  3. #3
    Star Lounger
    Join Date
    Apr 2002
    Location
    Boise, Idaho, USA
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: SQL behind form (Access 2002)

    okay, way weird - now they all work the same way. I need to do some further research to see if I can either repeat the error or figure out what changed from earlier.

    Thanks - I'll repost the problem if I can't solve it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •