Results 1 to 5 of 5
  1. #1
    Kati
    Guest

    TOC links not working

    I am creating a new document that includes a table of contents. Most of the TOC is fine, however, the cross references to two of the chapter headings do not work properly. Basically, they link just fine when I have the Show/Hide Formatting button set to on. When I set it to Hide, the links don't work anymore. I have some section breaks set up in between the chapters because if I remove them, the headings end up on the same page, even if I set up page breaks. I also have section breaks set up in other parts of the document and it doesn't affect the table of contents function. I have tried everything I can think of---including deleting the headings and recreating them and putting everything in a new document, but nothing works.

    Any suggestions???? I am at a complete loss! Please help---it is a quite extensive user guide and I don't really want to start over! <img src=/S/crybaby.gif border=0 alt=crybaby width=15 height=15>

  2. #2
    KTYorke
    Guest

    Re: TOC links not working

    TOC's can be a little tempermental.
    Did you use the TOC wizard to insert the toc?
    When you say "the cross reference to two of the chapter headings do not work properly" do you mean it comes up as an error, or the page numbers are wrong... could you be a little more specific with that?
    Is there anything different about these two headings? Are they a standard name or a custom name?

    One thing you can at least check...(if you haven't already <img src=/S/wink.gif border=0 alt=wink width=15 height=15>) whatever heading style the missing chapter heads are... is that style listed and marked with a TOC level when you choose Insert>Index and Tables>Options?
    hope some of this helps... and if not then hopefully elaborating on exactly what you're doing can help.
    have fun

  3. #3
    Kati
    Guest

    Re: TOC links not working

    What I mean by they don't work is that they appear OK on the page--page numbers are OK & the heading shows correctly, but when I click on the page number to jump to the page, nothing happens.... <img src=/S/bummer.gif border=0 alt=bummer width=15 height=15>

    I did not use the TOC wizard, I inserted it using Insert>Index and Tables>---which is how I ususally do it. I am certian that the heading level is fine--it is a style set up as part of the template--it is heading level 1.

    Thanks for trying to help...this is a really crazy thing...nobody in my office seems to know either....I have tried everything, as I said, including deleting and reinserting the TOC...nothing works! <img src=/S/dizzy.gif border=0 alt=dizzy width=15 height=15>

    Hope the extra info helps!

  4. #4
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: TOC links not working

    > Basically, they link just fine when I have the Show/Hide Formatting button set to on. When I set it to Hide, the links don't work anymore.

    >I have some section breaks set up in between the chapters because if I remove them, the headings end up on the same page, even if I set up page breaks.

    I can't replicate it, but then again, my documents are not that complicated.

    It seems crazy, but is there any chance that the heading itself or the immediately preceding page break or paragraph symbol is "hidden" text? That is one of the few possible explanations for the second of these odd behaviors, and possibly it explains the first as well. If not, there appears to be no reasonable explanation for Word's behavior.

  5. #5
    Kati
    Guest

    Re: TOC links not working

    Thank you! It actually worked.... <img src=/S/joy.gif border=0 alt=joy width=23 height=23>I didn't realize that I had any of that set up as hidden text. I have a portion of the document set to hidden text and I guess it just followed, even though I thought I had turned it off! How silly of me! <img src=/S/threadhead.gif border=0 alt=threadhead width=28 height=31>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •