Results 1 to 5 of 5
  1. #1
    Star Lounger
    Join Date
    Sep 2001
    Location
    Bangkok, Thailand
    Posts
    56
    Thanks
    0
    Thanked 0 Times in 0 Posts

    WD2002SP2 - Text in Visio Objects do not print (MS WOrd 2002 (10.4524.4219

    I have created beautiful organisation charts in Visio 2002 (standard 2002 SR-1 (10.0.2514)), then inserted them into Word 2002, resized the Visio object until it all looks just fine on screen BUT when I print the page the boxes and lines print but the text in the boxes does not print.

    (A colleague also has the same problem, but he is running Word 98 and it happens with documents he has been sent - he doesn't have Visio to create his own charts. Incidentally, we are both printing to different models of HP Laserjets the exhibit no other problems.)

    This is extremely frustrating! What is worse it does not happen with all documents, but at least when it does happen within a particular document it always happens with that document (the converse also applies).

    One complicating issue could be that the original Word document was probably created in an earlier version of Word (maybe as far back as Word 95!) and similarly for the Visio object.

    ANyone got any bright ideas?

  2. #2
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts

    Re: WD2002SP2 - Text in Visio Objects do not print (MS WOrd 2002 (10.4524.

    I am guessing here but I would say that the import filter that Word is using is either buggy or just plain confused with the software upgrades that have occurred with your Visio and Word files. Certainly I was confused by whether your beautiful graphics and documents were actually created in the latest version of both softwares or just most recently edited there.

    Resizing the graphic may also have caused the filter a problem - if so make sure the Visio file is rightsized before importing..

    If opening and saving the Visio files in the same version that Word's Visio filter expects does not have any effect then I would go back to the traditional method of getting graphics into Word.

    This involves either opening the Visio file and either:
    Copying the graphic, going to Word and using Paste Special (As Picture) to get the graphic OR
    Save As and make the graphic an EMF or WMF, then go to Word and do an Insert > Picture > From File an placing the graphic file in that way.

    I would expect either of these methods to work. If this still fails, perhaps there is a font issue with your printer driver. Do you have the latest drivers? Are there fonts loaded on a printer hard disk?
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  3. #3
    5 Star Lounger
    Join Date
    Dec 2000
    Location
    Calgary, Alberta, Canada
    Posts
    818
    Thanks
    6
    Thanked 1 Time in 1 Post

    Re: WD2002SP2 - Text in Visio Objects do not print

    FWIW this is an interesting problem that I have never encountered myself. I am not sure how you are placing the Visio graphics in the Word document. I work with W2K and Office 2K both home and at client's site., but I have worked Visio 4 and 5 and Word 97 to Word 2K. I find that placing the graphics in a text box and then anchoring the text box to a paragraph works 95% + of the time -- sometimes I get a little reluctance <img src=/S/confused.gif border=0 alt=confused width=15 height=20> on the part of Word to play nice with the Text box, but I can usually overcome its benign antics. HTH <img src=/S/compute.gif border=0 alt=compute width=40 height=20>

    Ron M <img src=/S/smile.gif border=0 alt=smile width=15 height=15> <img src=/S/smile.gif border=0 alt=smile width=15 height=15> <img src=/S/smile.gif border=0 alt=smile width=15 height=15>

  4. #4
    Star Lounger
    Join Date
    Sep 2001
    Location
    Bangkok, Thailand
    Posts
    56
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WD2002SP2 - Text in Visio Objects do not print

    My typical problem Word document is about 80 pages long (say a joint venture agreement or contract conditions) that was first drafted about 7 or 8 years ago, revised frequently and reused for new projects. Sorting out its exact genesis is beyond me The Visio organograms have been created in various versions of Visio from early versions to the latest with all the updates. Word is similarly fully updated with all the MS scratches to try to get it right.

    The way I insert Visio objects is through the Word Insert|Object|Create from File process. It always goes in just fine and shows on screen perfectly.

    Then comes the problem: in some documents printing is okay -- always. In other documents the text in the Visio organogram boxs just will not print -- ever!

    Interestingly, we've been experimenting with the copy / paste process for insertion and get similar results.

    I think the suggestion that the problem is in the Visio filter in Word is on the right track, but without a means to repeat the problem on demand I doubt I'm going to get much further in solving this annoying problem at the moment - I'm more of a wordsmith, and certainly not a programmer type, so any further investigation on my part is going to take enormous amounts of time playing in the fog that is Microsoft Office.

    Thanks for your help folks, just hope some-one, one day can sort the bug out.

  5. #5
    5 Star Lounger
    Join Date
    Dec 2000
    Location
    Calgary, Alberta, Canada
    Posts
    818
    Thanks
    6
    Thanked 1 Time in 1 Post

    Re: WD2002SP2 - Text in Visio Objects do not print

    Last ditch effort - sometimes this works if the document is corrupted a bit. Save original .doc to an .rtf file. Close everything down. Open the .rtf and save it as a .doc file. Close everything down. Open the new .doc file and re-insert the Visio diagram and see if that works. If this does not help, then short of retyping the whole thing, I am at a loss for remedies <img src=/S/brickwall.gif border=0 alt=brickwall width=25 height=15>. HTH

    Ron M <img src=/S/smile.gif border=0 alt=smile width=15 height=15> <img src=/S/smile.gif border=0 alt=smile width=15 height=15> <img src=/S/smile.gif border=0 alt=smile width=15 height=15>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •