Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    654
    Thanks
    10
    Thanked 0 Times in 0 Posts

    Themes are Not Valid Themes (xp sp1 Professional)

    I save my desktop as a theme under appearance and settings as I like the way it looks, When I create a new user and then try to apply the old theme that I just saved to this new user / account it says it is not a valid theme. Is it a theme or not especially when you can download themes????
    Jerome

  2. #2
    Silver Lounger Bruce K's Avatar
    Join Date
    Apr 2002
    Location
    Phoenix, Arizona, USA
    Posts
    1,876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    Hi, Jerome ~

    What do you mean when you say you "save my desktop as a theme"? Your desktop is just 'wallpaper' or a 'background' A 'theme' is a collection that includes wallpaper, visual style, icons, cursors, sounds, fonts and the like all saved as one file.

    If you like the way everything looks/works, then go to 'Display Properties' > 'Themes' tab > 'Save As...' button and save it to a location where you might store them. Then you can always load this theme or others from the drop-down box from the 'Themes' tab.

    Although similar, don't confuse the themes you download from the interent with the themes you save with what you already have.

  3. #3
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    654
    Thanks
    10
    Thanked 0 Times in 0 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    Yes I right click on the desktop get display properties see theme and save it as klein.theme in the root directory, no problem. I even reload it and it loads fine.
    Problem is when I log out and go to another user on the system and log in and then try to use the klein. theme file it says it is not a valid file.
    Have tried this with multiple names and just does not seem to workl Thanks
    Jerome

  4. #4
    Silver Lounger Bruce K's Avatar
    Join Date
    Apr 2002
    Location
    Phoenix, Arizona, USA
    Posts
    1,876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    Have you tried loading it my double-clicking the theme file?

    I haven't used themes across multiple accounts, so I apologize if I cannot help further. <img src=/S/sorry.gif border=0 alt=sorry width=15 height=15>

  5. #5
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    Jerome, I think the problem is that XP's visual styles are digitally signed, so once settings are save for a particular user, they work - and won't for anyone else. If you're interested, you can download StyleXP which allows non-signed/checksummed themes with custom visual styles. Otherwise, the edited visual style defaults back to Windows Classic.
    -Mark

  6. #6
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    654
    Thanks
    10
    Thanked 0 Times in 0 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    Bruce: double clicking only works in the original account.
    MARK I downloaded stylexp and it works in the original account. When I switched users even though they are both set up as administrators. I cannot get into the original desktop and if i move it to the root directory, when I am in the original account, and then try installing it into the new account, It wont let me access the file to run setup.
    Why does winxp lock me out of the files???
    Jerome

  7. #7
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    654
    Thanks
    10
    Thanked 0 Times in 0 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    I uninstall the style program and just installed it on the 2nd account that I am trying to get the themes into. And it still won't read the saved theme on the second account, ie no better than native windows xp.

  8. #8
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    Do you have the "Make Private" checked in the sharing of each account?

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  9. #9
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    654
    Thanks
    10
    Thanked 0 Times in 0 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    I fixed it. If you save the theme, on my computer you then have to go to the saved file and go to properties, mark share, unmark read only, go to security permissions and even though set to EVERYONE, have to go to advanced add administrator, okay and then give full permissions to the administrator.
    I am not clear why everyone does not include administrator. but it works
    Jerome

  10. #10
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    Jerome, glad to hear it. Administrators should be included in the Everyone group unless something explicitly denies it, as denials take precedence. Are you certain it wasn't one of the other steps you described that made the theme file usable by other accounts?
    -Mark

  11. #11
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    654
    Thanks
    10
    Thanked 0 Times in 0 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    No I am certain that adding administrators was the key. I don't know how to examine the EVERYONE Group to see why it would not pick up administators or exclude them unless specifically added.
    Strange
    Thanks
    Jerome

  12. #12
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,580
    Thanks
    5
    Thanked 1,058 Times in 927 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    Jerome, 'Everyone' is a special group in which all users are automatically inlcuded. You can not manipulate the group members.

    Joe
    Joe

  13. #13
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    654
    Thanks
    10
    Thanked 0 Times in 0 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    Yes, but then why do you have to add Administrator to the permissions, if everyone has administrator class and everyone should include everyone.
    This sounds weird hope it makes sense
    Jerome

  14. #14
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,580
    Thanks
    5
    Thanked 1,058 Times in 927 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    Because the permissions for the everyone group are not always everything. Did you check whether the permissions were inherited or directly set? Also, XP SP1 changed some of the default permissions for the 'everyone' group (I'm not sure uner what conditions though).

    Joe
    Joe

  15. #15
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    654
    Thanks
    10
    Thanked 0 Times in 0 Posts

    Re: Themes are Not Valid Themes (xp sp1 Professional)

    I copied these files over to a new computer from win 2000 computer through a tape backup / restore. So ? inherited. versus directly set
    Jerome

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •