Results 1 to 9 of 9
  1. #1
    New Lounger
    Join Date
    Mar 2003
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Disappearing Relationships (2002 SP2)

    A simple question: in the tools - relatonships window, all my relationships have disappeared, but all the tables remain present as laid out when the relationships were set.
    I cannot be sure, but the relationships' disappearance may have been at the same time as I used the database splitter. The database continues to work ok (at least it appears to)! If I try to set up any of the relationships again, part of the window (to define the relationship) is greyed out (e.g. I cannot tick the "maintain referential integrity box). I've searched the help and scoured my books, but not seen any obvious mention of this.
    Is this disappearance of the relationships "normal" with use of the splitter, or have I done something incorrectly? If the second, what are the most likely causes and what do I need to do to correct the situation?
    Before I spotted the situation a copy of the database was put in use, and I'm concerned that I need to resolve this fairly quickly.
    Thanks in advance for any help on this topic.

    rgds,
    Dave

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Disappearing Relationships (2002 SP2)

    Where are you trying to set the relationships? You should do this in the backend database (the one containing the tables), not in the frontend (the one with all the other objects, and links to the tables in the backend.)

    Do you have primary keys on your tables? If you don't, or if they got lost somehow, you can't set referential integrity.

  3. #3
    New Lounger
    Join Date
    Mar 2003
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Disappearing Relationships (2002 SP2)

    Hans,

    The relationships were all set (and appeared correctly) before the database was split.
    In the front end, the relationships window is as I described - the tables are present, but no relationships. In the backend, the entire relationships window is blank.

    Are you saying that using the splitter requires all the relationships to be re-established? (Bear in mind I'm not saying definitely this change occured at the time of the split - its just my suspicion, as I don't think Ive done anything else that would have caused it).

    Dave.

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Disappearing Relationships (2002 SP2)

    The database splitter shouldn't change anything in the relationships. It has always worked correctly for me, but there was another thread recently about relationships being lost after splitting. (This is starting to sound like a marriage counseling site <img src=/S/grin.gif border=0 alt=grin width=15 height=15>)

    Open the backend.
    Open the Relationships window.
    Click the Show All button on the Relationships toolbar.
    Do you see anything now?

    If not, your relationships are definitely lost, but I don't have any idea about why. I repeat, splitting shouldn't have this effect...

    If you are going to recreate them, you should do so in the backend (as I mentioned in my previous reply).

  5. #5
    New Lounger
    Join Date
    Mar 2003
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Disappearing Relationships (2002 SP2)

    Hans,

    In the backend relationship window there is......nothing.
    But the database appears to work.

    If somebody else has experienced this problem, perhaps there is a real bug that needs sorting. The message clearly is to document the relationships and / or back up the database before doing the split, and then check all is well directly after the split.

    thanks for your prompt help,
    Dave.

  6. #6
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,623
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: Disappearing Relationships (2002 SP2)

    By work, do you mean that the referential integrity is still functional? If so, it sounds like some sort of corruption may have occurred - or we may be seeing some sort of bug with 2002. As Hans noted, this is the second instance of an issue like this. Is it possible that at some point the tables database was imported into a new empty database, and the option for copying relationships was turned off?
    Wendell

  7. #7
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Disappearing Relationships (2002 SP2)

    In the relationship window in the back end, have you click on Relationships-->Show All?
    Charlotte

  8. #8
    New Lounger
    Join Date
    Mar 2003
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Disappearing Relationships (2002 SP2)

    Yes, the referential integrity appears intact. The user is entering data and queries and I have witnessed that forms appear to work without hitch. (However, I'm now away from the user site at the moment, so cannot inspect the tables in detail.)
    Your point about imports is relevant, as to put the database live with the user I did replace one or two tables with empty versions of those tables. This fact had completely slipped my mind for the original post as I thought I had checked the relationships were intact, but its just possible I made an error at that stage.
    Either way, whether I made an error or there is a weakness in Access, I will do a manual correction.

    thanks fro your help.

  9. #9
    New Lounger
    Join Date
    Mar 2003
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Disappearing Relationships (2002 SP2)

    Yes!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •