Results 1 to 5 of 5
  1. #1
    2 Star Lounger
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    158
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Macros and Forms Object Library (Word 2000/XP with all updates)

    (Edited by HansV to create link to MSKB article)

    I have a macro which allows me to add the extra diacritical marks to Hebrew text. The macro is in the Office startup directory and starts up correctly. However, when I go to use it, I get the message: The macro cannot be found or has been disabled because of your Macro security settings". These have been changed, but made no difference. a search on MS Technet produced article <!mskb=328157>Microsoft Knowledge Base Article 328157<!/mskb> which describes the problem and offers a solution. However, when I follow the instructions "Select the MS Forms 2.0 Object Library as a Reference" and select FM20.dll, the selection just doesn't seem to stick. As soon as I close the VB Editor, the selection is gone. Are the instructions in 328157 totally correct, or am I making a 'finger' mistake? All service packs and patches have been installed, and this problem is in both Word 2000 and Word XP. The Word XP installation is a full installation of all options run directly from hard disk, so I doubt I'm missing any files.

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Macros and Forms Object Library (Word 2000/XP with all updates)

    Setting a reference should be "sticky". Are you absolutely sure that the check box next to the reference to the Microsoft Forms 2.0 Object Library is actually checked before you click OK in Tools |References...? Have you tried saving the template or document containing the macro from the Visual Basic Editor after setting the reference?

  3. #3
    2 Star Lounger
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    158
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Re: Macros and Forms Object Library (Word 2000/XP with all updates)

    Thanks for your prompt reply. Yes, I'm sure that the check mark has been set. According to the MS article, after I set the check mark, I'm supposed to close and go back to my original document. I tried saving 'Doc1' once, closing Word and then reopening, but that made no difference. Before I close the VB Editor, am I supposed to save something there? As this is a macro that I probably will be using a lot, it would be handy if I could get it to be part of Normal.dot. But that might also not be a good idea. I'd just be happy if it worked when I need it!

    Thanks for now. any other suggestions?

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Macros and Forms Object Library (Word 2000/XP with all updates)

    Why don't you copy the macro to Normal.dot? Don't forget to set the reference again (it is a document-specific setting). Then save Normal.dot from within the Visual Basic Editor (it shouldn't be necessary to do it there, but it doesn't harm either). Quit Word and start it again. See if you can run the macro.

  5. #5
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Re: Macros and Forms Object Library (Word 2000/XP with all updates)

    Maury,

    Since you say the macro is in the startup directory, I assume you mean that the macro is in a global template, other than Normal.dot, which is in the startup directory?

    As Hans mentioned, setting the reference is a document-specific property, which means that in order to have this setting 'stick' with your global template, you must first open the global template as a document, then in the VB Editor, look in the Project Explorer window, make sure your global template is selected, and then do the Tools > References to set the reference.

    You can then save your global template by either pressing Ctrl+S in the VB Editor (making sure you have the global template selected in the Project Explorer), or else switch back to Word and save the global template before closing it.

    Gary

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •