Results 1 to 13 of 13
  1. #1
    3 Star Lounger
    Join Date
    May 2003
    Location
    Mid-Cheshire, England
    Posts
    275
    Thanks
    1
    Thanked 3 Times in 3 Posts

    Language setting (2000 up to date)

    I have checked the settings, and I do mean all, several times, in Windows XP Home & Word 2000 are English UK the spell checker frequently reverts to English US. This seems to happen with a document that has been created on a computer set to English US. Even when I scan such a document the spell check reverts to English US. Can I force the spell check to work only in the Language of my choice?

  2. #2
    Super Moderator
    Join Date
    May 2002
    Location
    Canberra, Australian Capital Territory, Australia
    Posts
    5,054
    Thanks
    2
    Thanked 417 Times in 346 Posts

    Re: Language setting (2000 up to date)

    Hi Malcolm,

    The language setting for each document is document specific, though more than one language can be used in a document (preferably by using different styles for each).

    If you proof a document that was intentionally created as US english using UK english, should Word would then infer that language-specific spelling & punctuation differences are errors? I don't think so. It'd be even worse if you were to proof a non-english language with an 'english' proofing tool.

    If you really want to go down this path, a macro solution would probably be needed, to change each document's language to UK english or whatever as it is opened.

    Cheers
    Cheers,

    Paul Edstein
    [MS MVP - Word]

  3. #3
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Language setting (2000 up to date)

    Word's spell checking is closely tied to the keyboard language setting. Make sure that your keyboard language is set to UK English, not US English. In Windows XP, this setting is in the Regional Settings control panel, in older versions of Windows in the Keyboard control panel.

  4. #4
    3 Star Lounger
    Join Date
    May 2003
    Location
    Mid-Cheshire, England
    Posts
    275
    Thanks
    1
    Thanked 3 Times in 3 Posts

    Re: Language setting (2000 up to date)

    I had already done what you suggest & deleted the English US option there.

  5. #5
    3 Star Lounger
    Join Date
    May 2003
    Location
    Mid-Cheshire, England
    Posts
    275
    Thanks
    1
    Thanked 3 Times in 3 Posts

    Re: Language setting (2000 up to date)

    If I change the setting from US to UK while spell checking the change reverts to US when the next spelling `error' is reached. For example `cheque' & `check'.

    I assume the macro could be created with the Record Macro Tool & I will try this approach.

    Thank you for your helpful response.

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Language setting (2000 up to date)

    I have Word 2002 (and a non-English version to boot), so I don't know whether the following applies to Word 2000. In Tools | Language | Set Language..., there is a check box "Automatically determine language". If this option is available in Word 2000, try clearing the check box. Then, select the entire document and set the language to English UK.

  7. #7
    Super Moderator
    Join Date
    May 2002
    Location
    Canberra, Australian Capital Territory, Australia
    Posts
    5,054
    Thanks
    2
    Thanked 417 Times in 346 Posts

    Re: Language setting (2000 up to date)

    Hi Hans,

    The same setting is in Word 2000 too. Not sure how Malcolm gets 'check' to show up as an error when 'cheque' is meant, though ...

    Cheers
    Cheers,

    Paul Edstein
    [MS MVP - Word]

  8. #8
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Language setting (2000 up to date)

    Hi Malcolm:
    2 additional thoughts.
    1. I'm not sure about Win XP, but in Win 98, there's a language setting in BOTH Control Panel/Regional Settings & in Control Panel/Keyboard.
    2. Since the document is created in US English, have you selected the entire document & then applied English (UK) by going to Tools/Language/Set Language/English (UK)?

    Cheers,

  9. #9
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Language setting (2000 up to date)

    Within the past week or two there was a thread here on the Australian spell checking problem, which sounds like the same issue. Hope you are able to find it.

  10. #10
    3 Star Lounger
    Join Date
    May 2003
    Location
    Mid-Cheshire, England
    Posts
    275
    Thanks
    1
    Thanked 3 Times in 3 Posts

    Re: Language setting (2000 up to date)

    Is this a misunderstanding or did I get it the wrong way round? I meant `cheque' shows as an error for `check' because the checking defaults to English US when I have it set to English UK. I have one document where the spell check changes from UK to US & back again!

    I have wondered if the problem started with me taking over a set of Word files from my predecessor as honorary secretary of a social group.

  11. #11
    3 Star Lounger
    Join Date
    May 2003
    Location
    Mid-Cheshire, England
    Posts
    275
    Thanks
    1
    Thanked 3 Times in 3 Posts

    Re: Language setting (2000 up to date)

    As it happens that check box is greyed out & clear.

  12. #12
    3 Star Lounger
    Join Date
    May 2003
    Location
    Mid-Cheshire, England
    Posts
    275
    Thanks
    1
    Thanked 3 Times in 3 Posts

    Re: Language setting (2000 up to date)

    I'll take a look - thank you.

  13. #13
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Language setting (2000 up to date)

    The thread Jefferson Scher mentioned has been updated, so it was easy to find again - see <post#=254648>post 254648</post#>, in particular the links in the second post in that thread.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •