Page 1 of 2 12 LastLast
Results 1 to 15 of 22
  1. #1
    New Lounger
    Join Date
    May 2003
    Location
    Middlesex, New Jersey, USA
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    No mouse in Safe Mode

    I had some problems with my computer a couple of weeks ago where it would only boot in Safe Mode. Somehow I got it back up and running but in the process I lost the mouse in Safe Mode. When I boot in Safe Mode I get an error message: "Windows did not detect a mouse..." This is not a problem at the moment since it is booting up fine normally but I am comcerned that if I lose it again in the future it will be awfully hard to do anything in Safe Mode without a mouse.
    I am running Windows 98SE on a 350mhz Pentium II machine with a phoenix BIOS. Any and all help would be much appreciated

  2. #2
    5 Star Lounger
    Join Date
    Feb 2001
    Location
    Dallas plus 20 miles or so, Texas, USA
    Posts
    876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No mouse in Safe Mode

    If it is an optical mouse or maybe a USB mouse the drivers might not load in safe mode. I usually try to keep a regular old fashioned PS/2 mouse hanging around in the event of an emergency.

  3. #3
    New Lounger
    Join Date
    May 2003
    Location
    Middlesex, New Jersey, USA
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No mouse in Safe Mode

    It's the same mouse I've always had and it is a PS-2 mouse.

  4. #4
    5 Star Lounger
    Join Date
    Feb 2001
    Location
    Dallas plus 20 miles or so, Texas, USA
    Posts
    876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No mouse in Safe Mode

    How did you get it back after you lost it the first time?

  5. #5
    New Lounger
    Join Date
    May 2003
    Location
    Middlesex, New Jersey, USA
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No mouse in Safe Mode

    It was the whole computer I lost. After trying a number of things I disconnected the scanner which was apparently the cause of the problem and restored a previous version of the registry. In the process I somehow lost the mouse in Safe Mode.

  6. #6
    5 Star Lounger
    Join Date
    Feb 2001
    Location
    Dallas plus 20 miles or so, Texas, USA
    Posts
    876
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No mouse in Safe Mode

    Well, don't know what to say Ed...a PS2 mouse is about the most basic mouse that exists and if W98 is not picking it up, then maybe a reinstall might be in order. You might also try booting from a floppy and see if that helps next time.

  7. #7
    New Lounger
    Join Date
    May 2003
    Location
    Middlesex, New Jersey, USA
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No mouse in Safe Mode

    Mike-The mouse comes up just fine in Normal boot up but not in Safe Mode. I'm apparently picking up the mouse driver later in the boot up sequence in the files that are bypassed when you boot in Safe Mode. The question is: how do I get the mouse driver early in the sequence so that I have a functioning mouse in Safe Mode? Thanks for you efforts.

  8. #8
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: No mouse in Safe Mode

    Unfortunately, my Win98SE machine is down right now with a dead hard drive ("click of death!"), so I can't try this. I've never "lost" the mouse in Safe Mode, but have in normal boot had Win98 refuse to load the mouse driver. On a number of occasions, I've then booted to Safe Mode and opened Device Manager. Often you will see multiple entries for various devices. DELETE all the entries that appear for PS/2 mouse and re-boot into normal mode. Hopefully, Win98 will "re-identify" a PS/2 mouse and THEN you could re-try Safe Mode to see what happens. Other than that, I don't know of a workaround to get Windows to load the mouse earlier in the boot process.

    I should also mention that on one or two occasions when this has happened to me, it has turned out that the mouse was "dead," but I wouldn't suspect that in your situation since it's OK in booting to Normal mode.

  9. #9
    New Lounger
    Join Date
    May 2003
    Location
    Middlesex, New Jersey, USA
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No mouse in Safe Mode

    In Device Manager in Driver File Details for the mouse it shows two driver files: C:WINDOWSSYSTEM4DMOUSE.VXD and C:WINDOWSSYSTEMVMN32.VXD[vmouse.vxd] are you suggesting I delete one or both of these and then reboot?

  10. #10
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: No mouse in Safe Mode

    I'm suggesting you delete the MOUSE, so yeah, I guess you could say that. Immediately upon rebooting, Win98 should "find" and re-install whatever mouse is attached, normally a PS/2 mouse if you have one plugged in to the mouse port.

  11. #11
    New Lounger
    Join Date
    May 2003
    Location
    Middlesex, New Jersey, USA
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No mouse in Safe Mode

    Thanks Big Al
    If I do this and it doesn't work will I be able to get the Mouse back by restoring the registry using "scanreg/restore"?

  12. #12
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: No mouse in Safe Mode

    Well, I've never, ever had to do that, so I can't definitively say one way or the other. BUT, I am 99% sure it won't come to that. If you delete the mouse entry in Device Manager, reboot the computer and Windows doesn't "see" that there's a mouse installed (plugged in) to the PS/2 mouse port, then there is probably a DEAD mouse on your hands and I would try another mouse BEFORE I would resort to restoring the registry.

  13. #13
    New Lounger
    Join Date
    May 2003
    Location
    Middlesex, New Jersey, USA
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No mouse in Safe Mode

    OK I deleted the mouse in Device Manager and yes Windows picked it up and reinstalled when I re-booted but I still don't get it in Safe Mode. As before when I boot into Safe Made I get a box saying there is no mouse connected and I have no mouse functionality yet it works perfectly fine when I boot up normally. Thanks for your efforts. Do you have any other ideas?

  14. #14
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: No mouse in Safe Mode

    Check out this site for info. http://www.jsifaq.com/SUBE/Tip2400/rh2423.htm
    It is about no mouse and/or keyboard in safe mode.

    Bob
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  15. #15
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: No mouse in Safe Mode

    Scratch that last one, Ed.
    It's for Win2000 or XP, and I went back to your first post and saw that you are running SE. However, I would google search for "no mouse in safe mode". There were a lot of other possibilities there, including 98 or SE.

    Bob
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •