Results 1 to 8 of 8
  1. #1
    Star Lounger
    Join Date
    May 2003
    Location
    Pennsylvania, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts

    File Associations

    I changed the default file association for text files from Notepad to Word. Now when I click on a text file name, Word comes up, but it claims it can't find the file. After clicking through several screens of this, it gives me the blank Word screen. If I click on File, the name of the file I'm trying to open is there.

    The problem seems to be with long file names because on the "cant find file" screens, the path is cocuments... instead of c:My Documents.....

    How can I make these files open automatically??

    (Note: I followed the procedure in the article on multiple file associations from WWW, so I could right-click on the file name, and it works. But I would like to just click the file name like I can do with all other file types.)

    Thanks for the help.

    Don.

  2. #2
    3 Star Lounger
    Join Date
    Dec 2000
    Location
    New Zealand
    Posts
    295
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    Don, I have to ask why??? Using Word to read text files is a bit of a sledgehammer to crack a peanut. If you're not happy with Notepad, which is quite likely as it is pretty useless, there are plenty of free replacements around which are far superior. Check somewhere like <A target="_blank" HREF=http://www.download.com>http://www.download.com</A>. Of course I could have missed the point entirely!!! <img src=/S/smash.gif border=0 alt=smash width=30 height=26>

  3. #3
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Northern, California, USA
    Posts
    1,886
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    Personally, I use HTML-Kit for text, you can check it out <A target="_blank" HREF=http://www.wopr.com/cgi-bin/w3t/showflat.pl?Cat=&Board=free&Number=12594&page=5&vi ew=collapsed&sb=5>here, in Software Finds.</A>

    It's Great!
    <IMG SRC=http://www.wopr.com/w3tuserpics/Kel_sig.gif>
    Moderator:<font color=448800> Pix Place, Internet Explorer</font color=448800>
    <small>www.kvisions.com

  4. #4
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    Hi Don:

    I agree with the others that have responded. Nevertheless, to fix the problem:
    1. Open any folder window
    2. View/Folder Options/File Types tab
    3. Scroll to text file
    4. Edit/select Open/Edit
    5. In Application used to perform action, make sure that the path is in quotes.

    Also, I'm going from memory (a scary thing) but make sure that after the path there's a %1

    Hope this helps.

  5. #5
    Star Lounger
    Join Date
    May 2003
    Location
    Pennsylvania, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    Thanks for all your suggestions. Phil's suggestion worked (although he didn't mention that the %1 after the path has to be in quotes also).

    As for the reason to use Word, I do a lot of passing fairly large files from Access to Word, and I often want to convert the text to other formats, put it into a table, sort it, etc., etc. Word is the best way to do this quickly and easily. (Most of my files are too big for Notepad, and so I get the box asking me if I want to use WordPad instead.)

    Don.

  6. #6
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    England
    Posts
    1,306
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    Hi Don
    I think Phil has hit the nail. The reason you get an error message is the space between My and Documents. Putting the path in quotes solved it for me. Personally, I wouldn't use Word to read text files - takes too long to open. Notepad is instantaneous.
    Rgds

  7. #7
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    Hi Don:

    If you want an intermediate solution, which keeps text files associated with Notepad (or a replacement), but allows you to open them in Word, add a command to your context menu. (I'm going by memory again, & you know what that means <img src=/S/laugh.gif border=0 alt=laugh width=15 height=15>.

    Go through the same steps to get to the file association dialog box for text files. This time, instead of selecting the action, "Open", create a new action. Call it "Open with Word" (or anything you want). Then for application used to perform this action, browse to Word. Use the same path & settings you now have for Open. Don't forget the quotes & the "%1" <img src=/S/laugh.gif border=0 alt=laugh width=15 height=15>. Now you should have an entry on a context menu when you right click a text file that says, "Open with Word". However, double clicking will still open text files with Notepad (if you change it back).

    Hope this helps.

  8. #8
    Star Lounger
    Join Date
    May 2003
    Location
    Pennsylvania, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File Associations

    Phil--Thanks. All is fine now. I did this as an intermediate solution, but now I don't have to right-click on the filename to get the menu to pop up.

    Don

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •