Results 1 to 4 of 4

Thread: Language

  1. #1
    JALS
    Guest

    Language

    I'm running Office 97 on a Windows NT4 workstation. In Word, the spell checker works properly checking my documents in English (United Kingdom). However in Excel the spell checker accepts only English (United States) spellings. I've tried deleting and restoring Normal.dot, Custom.dic and my profile and I've removed and re-installed Office 97. Can anyone help!

  2. #2
    WS Lounge VIP rory's Avatar
    Join Date
    Dec 2000
    Location
    Burwash, East Sussex, United Kingdom
    Posts
    6,280
    Thanks
    3
    Thanked 191 Times in 177 Posts

    Re: Language

    Hi,
    2 possibilities spring to mind: in Control Panel-Regional Settings is the regional setting set to English (US)? If so, try changing it to English (UK). Alternatively (and I'm guessing here that Excel97 is like Excel2000) try inputting a word such as 'colour' that the US spellchecker won't like. When it brings up the Not Found dialog, does it allow you to change the dictionary language?
    Hope that helps.
    Regards,
    Rory

    Microsoft MVP - Excel

  3. #3
    Platinum Lounger
    Join Date
    Feb 2001
    Location
    Weert, Limburg, Netherlands
    Posts
    4,812
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Language

    Hi JALS,

    In Excel 97, the language is kept in the registry :

    "My ComputerHKEY_USERS.DefaultSoftwareMicrosoftOffice8 .0ExcelSpell Checker"
    Item Name "Speller"
    Content (e.g.) : "2057/Normal"

    The trick is to find out what number the UK English dictionary is. I
    know US english is probably "2057/Normal" and Dutch appeared to be
    1043. So when I changed the key to read:
    "1043/Normal" and I restarted XL, my XL speller started using Dutch
    (very useful discovery!!)

    The UK number is (I think):

    "1033/Normal"

    Regards,

    Jan Karel
    Excel TA
    Jan Karel Pieterse
    Microsoft Excel MVP, WMVP
    www.jkp-ads.com
    Professional Office Developers Association

  4. #4
    JALS
    Guest

    Re: Language

    Thank you Rory and Pieterse,
    There is only one locale in the control panel - English (UK) and Excel 97 doesn't give you the option to change the default language like Excel 2000 does.
    The registry fix worked just right on a colleagues PC - but not on mine - even if I changed it to English US and then back to English UK it still checked US English. Dammit!
    I guess I'll just have to try for a green card.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •