Results 1 to 6 of 6
  1. #1
    Gold Lounger
    Join Date
    Dec 2000
    Location
    Hollywood (sorta), California, USA
    Posts
    2,759
    Thanks
    0
    Thanked 0 Times in 0 Posts

    AutoText with Style (Word 2002)

    I'm trying to apply a custom paragraph style to an autotext entry which consists of an address. The style formatting is defined as follows:
    Normal + Indent: Hanging 1.25", Tabs: 1", 1.25"

    But everytime I insert that autotext the style associated with it is Normal. The NEXT paragraph HAS the custom paragraph style applied. Word obviously expects me to hold my tongue is a certain position before this will work, but I can't figure it out. Can you?
    Kevin <IMG SRC=http://www.wopr.com/w3tuserpics/Kevin_sig.gif alt="Keep the change, ya filthy animal...">
    <img src=/w3timages/blackline.gif width=33% height=2><img src=/w3timages/redline.gif width=33% height=2><img src=/w3timages/blackline.gif width=33% height=2>

  2. #2
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: AutoText with Style (Word 2002)

    Hi Kevin:
    Assuming Word 2002 hasn't changed that aspect from 2000:
    When you created your autotext entry, did you include the paragraph mark? You need to, to keep the paragraph formatting. If so, zip a template with that autotext in it & I'll look at it.
    Cheers,

  3. #3
    Gold Lounger
    Join Date
    Dec 2000
    Location
    Hollywood (sorta), California, USA
    Posts
    2,759
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: AutoText with Style (Word 2002)

    Yes, I made sure to select the paragraph mark when I created the AT.

    Now get this. Ok, so here I am ready to take you up on your offer, so i put together a new template with the custom style and an autotext entry. I apply the style to the text, save the text as the autotext entry, save and test. And guess what? It works fine. Gee wiz.

    There must be something about my production template that is busted. Corrupt? I have no idea.

    If I get nowhere I'll PM you the production template so you can see for yourself. Thanks Phil.
    Kevin <IMG SRC=http://www.wopr.com/w3tuserpics/Kevin_sig.gif alt="Keep the change, ya filthy animal...">
    <img src=/w3timages/blackline.gif width=33% height=2><img src=/w3timages/redline.gif width=33% height=2><img src=/w3timages/blackline.gif width=33% height=2>

  4. #4
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: AutoText with Style (Word 2002)

    <hr>here I am ready to take you up on your offer...And guess what? It works fine.<hr>
    I wish I could cure all problems that easily...especially my own. <img src=/S/laugh.gif border=0 alt=laugh width=15 height=15> Still I'd be happy to test your production template (I have Word 2000, though).

  5. #5
    Gold Lounger
    Join Date
    Dec 2000
    Location
    Hollywood (sorta), California, USA
    Posts
    2,759
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: AutoText with Style (Word 2002)

    Here's the follow up on this issue. The problem was a corrupt global template. When I tested with the blank template, new autotext entry and a newly created custom style, the application of that style to the AT worked fine (as previously reported). But I could not get the style to "stick" to any AT in the existing global template (from which it needs to deploy). So I recreated the global template from scratch: File | New | Template and copied over all toolbars, code, autotext (except the suspected *bad* ones) and styles (again, except the troublemaker). And bingo, the whole business works fine.

    Moral: if all else fails, blame it on a corrupt template because that's probably what it is!
    Kevin <IMG SRC=http://www.wopr.com/w3tuserpics/Kevin_sig.gif alt="Keep the change, ya filthy animal...">
    <img src=/w3timages/blackline.gif width=33% height=2><img src=/w3timages/redline.gif width=33% height=2><img src=/w3timages/blackline.gif width=33% height=2>

  6. #6
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: AutoText with Style (Word 2002)

    Well, alls well that ... I always <img src=/S/crossfingers.gif border=0 alt=crossfingers width=17 height=16> keep backups of all my templates, so if it goes bad, at least it's not too hard to correct. Glad you got it solved & posted the solution.
    Cheers,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •