Results 1 to 7 of 7
  1. #1
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Report Footer Giving Wrong Result (2000)

    Hi,

    I've got a report that has a headers/footers by LastName/BusinessName and InvoiceNo. Everything is working fine with the exception the Total Amount Outstanding in the LastName/BusinessName footer. The result that it is giving is the TotalDue for the entire report, not just for that account. I've never had this happen before. I have many reports that have the Total by LastName..... in the corresponding footer and then the overall total in the report footer. I'm not sure what I'm doing wrong..

    The forumula I'm using is ...........=Sum([InvoiceTotal])-Sum([AmtAlloc]). As I said, this works fine in the report footer but nut in the LastName/BusinessName footer.

    Thanks,
    Leesha

  2. #2
    Silver Lounger
    Join Date
    Jun 2002
    Location
    Cheadle, Staffordshire
    Posts
    2,177
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Report Footer Giving Wrong Result (2000)

    Leesha
    It might help if we could see the report causing the problem.
    Can you attach a small demo ?

  3. #3
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Report Footer Giving Wrong Result (2000)

    Sure thing. Here you go.

    Leesha
    Attached Files Attached Files

  4. #4
    3 Star Lounger
    Join Date
    May 2002
    Location
    Toronto, Ontario, Canada
    Posts
    314
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Report Footer Giving Wrong Result (2000)

    Hi Leesha...

    When I tried to open the report in Preview mode, I got an error saying that there was a data type mismatch somewhere in the SQL statement for the report... Since the query itself opened up without error, I figured the problem was somewhere in the calculated fields in the report design... Therefore, the first thing I did was remove the expressions for the two totals fields in question... The report then opened in Preview fine...

    After that, I changed three things...
    1. <LI>changed the expression for Text104 (in LastName/BusinessName Footer) to "=Sum([InvoiceTotal]-[AmtAlloc])"
      <LI>created a new text box named "txtGrandTotal" in the same area (in LastName/BusinessName Footer)
      <UL><LI>set the control source to "=[Text104]"
      <LI>changed the RunningSum property to "Over All"
      <LI>set the Visible property to False

    <LI>I then changed the control source for Text87 (in the Report Footer) to "=[txtGrandTotal]"[/list]That fixed your sample report for me... Try that and let me know if it works for you... <img src=/S/smile.gif border=0 alt=smile width=15 height=15>

  5. #5
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Report Footer Giving Wrong Result (2000)

    Hi Trudi,

    Thank you for your post. I'm having a devil of a day. I made all your changes but my numbers are still wrong. Would you mind posting back to me what you did so I compare it to mine and see where I'm going wrong. I'm not sure why you got error messages when the report opens as I don't. Been a stumper of a day.

    Thanks,
    Leesha

  6. #6
    3 Star Lounger
    Join Date
    May 2002
    Location
    Toronto, Ontario, Canada
    Posts
    314
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Report Footer Giving Wrong Result (2000)

    Hi Leesha...

    Sure... I'll attach the database for you...
    One thing though... I took a second look at my report... The numbers didn't look quite right to me, so I played again... <img src=/S/doh.gif border=0 alt=doh width=15 height=15>

    Just to clarify... Here's how I see it...
    You are listing each invoice for each client...
    The Total Invoice Balance Due is the total of each invoice, less what's already been paid for that invoice...
    The Total Amount Due is the total of all outstanding unpaid amounts for each client's account...
    The Total Outstanding Balance / Credit Due is the total outstanding unpaid amounts for the entire report...

    Am I assuming correctly?? ...If so, look at the report named "Fixed rptBillingHistory2"...

    The changes I described in my prior reply are shown in "Fixed rptBillingHistory"... The new one has a couple more changes and another new text box... Sorry for the confusion... I don't know where my head was when I fixed it the first time... It's been one of those days for me too...

    <img src=/S/laugh.gif border=0 alt=laugh width=15 height=15> HTH... Have a great evening!
    Attached Files Attached Files

  7. #7
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Report Footer Giving Wrong Result (2000)

    Hi Trudi,

    Thanks so much for sending back the corrections you made. Your second version in fact is exactly what I needed. I figured it was just me doing something wrong. Not to worry re the numbers being wrong in the first version!

    Thanks again, hope your day perks up,
    Leesha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •