Results 1 to 8 of 8
  1. #1
    New Lounger
    Join Date
    Oct 2002
    Location
    Greenock, Renfrewshire, Scotland
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Updating Field Problem (Word 2000, SP-3)

    I have a document template with a number of macros, one of which updates the fields in the document. The template is used to create a user-guide and incorporates a number of screen-shot images.

    The problem that I'm having, currently, is that when I run a particular macro that updates the fields in the document, the screen-shots are also being removed. If you click in the space where the image was, you get an outline of the same size and shape as the image but the image does not seem to be there, nor anywhere else in the document.

    The relevant lines from the macro are:
    Set MainRange = ActiveDocument.StoryRanges(wdMainTextStory)
    MainRange.Fields.Update

    I have used this macro on a variety of versions of Word (97, 2K , XP) and on different platforms - W98, NT, W2K but this is the first time that I have come across this.

    I'd be gratefull for any thoughts or advice anyone can throw on this.

    Regards,

    Ian

  2. #2
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Updating Field Problem (Word 2000, SP-3)

    Maybe the pictures have been inserted as links to locations that are no longer valid?

    Could you right click on one of your pictures, select Toggle Field Codes, and let us know what code you see.

    StuartR

  3. #3
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Updating Field Problem (Word 2000, SP-3)

    Are the screenshots inserted as links, and if so, have the original picture files been (re)moved? If so, updating would have the result you see. There are two ways around this: either unlink the pictures (select a picture and press Ctrl+Shift+F9, or select Edit | Links..., select the pictures from the list and click Break Link), or lock them (Edit | Links... too) so that they won't be updated.

    Post back if this doesn't apply to your situation.

  4. #4
    New Lounger
    Join Date
    Oct 2002
    Location
    Greenock, Renfrewshire, Scotland
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Updating Field Problem (Word 2000, SP-3)

    Hi Stuart,

    The images were obtained by using HyperSnap to take a screen shot and, for the most part, were copied from HyperSnap and pasted into the document via the clipboard

    When I right-clicked on the image, I get options such as editing the picture, etc. There is no reference to Field Codes on that menu. However, I went into options and selected Field Codes which gave the following mesage:

    { INCLUDEPICTURE "file:///C:/DOCUME~1/sinci/LOCALS~1/Temp/HS5ClipImage_3f1babe5.jpg" * MERGEFORMATINET }

    which is, in fact, an image of an Oracle Applications login screen.

    I have two systems side by side, one running Word 2000 on a W2K platform, the other running Word XP, also on a W2K platform. The same document is on both systems and the problem occurs on the first but not on the second.

    Does this mean that there is a setting somewhere that I need to check?

    Thanks for your help.

    Regards,

    Ian

  5. #5
    New Lounger
    Join Date
    Oct 2002
    Location
    Greenock, Renfrewshire, Scotland
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Updating Field Problem (Word 2000, SP-3)

    Hi Hans,

    From my earlier post, you will see that the images have been inserted as links. Breaking the links, as per your message, solved the problem.

    However, as this is only happening on this particular system, is there an option somewhere that would allow me to import the image without a link being created?

    Many thanks,

    Ian

  6. #6
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Updating Field Problem (Word 2000, SP-3)

    Your best approach for the future might be to use Paste Special and choose a format such as Enhanced Metafile or Device Independent Bitmap depending on the type of picture that you are pasting.

    StuartR

  7. #7
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Updating Field Problem (Word 2000, SP-3)

    Hi Ian:
    As far as the difference between the two systems, is it possible that on one computer the field is locked against updates & the other isn't, as mentioned in posts above? Another explanation might be that one has access to the internet or the LAN or has permission to access the file & the other one doesn't.

  8. #8
    New Lounger
    Join Date
    Oct 2002
    Location
    Greenock, Renfrewshire, Scotland
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Updating Field Problem (Word 2000, SP-3)

    Hi Phil,

    I've now had the template running on SEVEN systems in the office. They are all supposed to have been cloned from the same build. Four have experienced the problem and three haven't. They all have the same LAN connection and I haven't been able to identify any differences in setup that the users may have amended. It's a real puzzle!.

    However, breaking the links, where appropriate seems to be the most straight-forward way of dealing with the problem and the users have been given the necessary instructions.

    Can I just take this opportunity to record my thanks to yourself, Stuart and Hans for the very valuable help in this matter.

    Regards,

    Ian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •