Results 1 to 9 of 9
  1. #1
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Minneapolis, Minnesota, USA
    Posts
    336
    Thanks
    2
    Thanked 4 Times in 4 Posts

    Phantom dual boot (XP Pro)

    When I boot up my machine, it asks me which operating system I want to use, Windows XP Professional or Windows XP Professional. This is no doubt the remnant of a failed installation, which I solved by starting over, booting to the CD, and making a clean installation. I didn't reformat (this was probably a mistake) but just opted for a clean installation. But somehow the machine thinks my earlier try is still on there. Is there any way to get rid of this situation without wiping the drive and starting all over? (I tried to search the forum for this topic, but search seems to be down.)

    Fafner

  2. #2
    Gold Lounger
    Join Date
    Feb 2003
    Location
    Wardrobe Malfunction Junction, Derry
    Posts
    2,953
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Phantom dual boot (XP Pro)

    Fafner-

    You should be able to remove it on the boot.ini tab of the msconfig utility. When you install Windows XP Home or Pro, it normally automatically formats your drive, unless you're upgrading with a previous flavor of Windows on that drive. See:

    289022: HOW TO: Edit the Boot.ini File in Windows XP

    SMBP

  3. #3
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Minneapolis, Minnesota, USA
    Posts
    336
    Thanks
    2
    Thanked 4 Times in 4 Posts

    Re: Phantom dual boot (XP Pro)

    Thanks. I have msconfig open to the boot.ini tab, and there are two lines under operating systems that read as follows:

    mulit(0)disk(0)rdisk(0)partition(1)WINDOWS="Micros oft Windows XP Professional" /fastdetect
    mulit(0)disk(0)rdisk(0)partition(1)WINNT="Microsof t Windows XP Professional" /fastdetect

    The first of these two lines is specified as the default, so the second is the line I need to get rid of. (I would hate to delete the wrong line). Incidentally, when I click Check All Boot Paths, the message box says that all lines in boot.ini are OK.

    So how do I delete this line in the System Configuration Utility, as you suggested? There doesn't seem to be an option for doing so. Or do I need to open boot.ini as a text file and delete that line? Will that work?

    Fafner

  4. #4
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Phantom dual boot (XP Pro)

    Just go to your C: folder, find boot.ini, right click, then click on open.
    The boot file can then be edited directly. Remove the second (non default ) line and then click on file | save.
    That should do it for you. <img src=/S/cheers.gif border=0 alt=cheers width=30 height=16>

    Bob
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  5. #5
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Phantom dual boot (XP Pro)

    Before you open BOOT.INI you should right click it, select Properties, and clear the Read-Only attribute, otherwise you will have problems when you try to save it.

    StuartR

  6. #6
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Minneapolis, Minnesota, USA
    Posts
    336
    Thanks
    2
    Thanked 4 Times in 4 Posts

    Re: Phantom dual boot (XP Pro)

    Worked like a charm. Thanks.

    Fafner

  7. #7
    Lounger
    Join Date
    Jan 2001
    Location
    MN
    Posts
    45
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Phantom dual boot (XP Pro)

    On a related note, is there a way to switch which OS is the default? I had W2k and added XP. This made XP the default OS. I would like W2K to be the default. I tried changing the order of apprearence in the boot.ini file as well as the default partition from (2) to (1). This only gives me a new option of "Windows (default)" that doesn't point to a legitiamate OS. Here is my boot ini file as it stands now.

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)WINNT="Microsof t Windows 2000 Professional" /fastdetect
    multi(0)disk(0)rdisk(0)partition(2)WINDOWS="Micros oft Windows XP Professional" /fastdetect


    Thanks, RJ

  8. #8
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Minneapolis, Minnesota, USA
    Posts
    336
    Thanks
    2
    Thanked 4 Times in 4 Posts

    Re: Phantom dual boot (XP Pro)

    Edit the boot.ini file so that the default line reads as follows:

    default=multi(0)disk(0)rdisk(0)partition(1)WINNT

    Will that work?

    Fafner

  9. #9
    Lounger
    Join Date
    Jan 2001
    Location
    MN
    Posts
    45
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Phantom dual boot (XP Pro)

    That did it. Thanks. RJ

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •