Results 1 to 8 of 8
  1. #1
    Star Lounger
    Join Date
    Jan 2002
    Posts
    74
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Spell check in non-existent text boxes (Word2000/SP3)

    All of a sudden, at the end of a spell check, Word has started asking me the following, even though there are no text boxes in the document.

    "In normal view Word can't check the spelling of text in text boxes.
    Do you want to switch to Print layout view so Word can check the text boxes?"

    Any ideas?


    TIA,



    David

  2. #2
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spell check in non-existent text boxes (Word2000/SP3)

    Hi Dave:
    Did you have text boxes in the document at one time? Have you switched to print layout view & looked to see if you have any boxes left over? Remember, if you create a text box without borders, it may appear invisible to you. Try switching to print layout, bring up the drawing toolbar, click on the select arrow & see if you can select anything. Look in the header/footer also.
    Hope this helps,

  3. #3
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Brussels, Brussel, Belgium
    Posts
    159
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spell check in non-existent text boxes (Word2000/SP3)

    hi David,

    this litle macro will delete all textboxes. it will not find textboxes that are grouped within other shapes.

    <pre>Sub DeleteAllTextBoxes()
    Dim TB As Shape
    For Each TB In ActiveDocument.Shapes
    If TB.Type = msoTextBox Then TB.Delete
    Next TB
    End Sub
    </pre>


  4. #4
    Star Lounger
    Join Date
    Jan 2002
    Posts
    74
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Re: Spell check in non-existent text boxes (Word2000/SP3)

    Thanks for the tip, but no, no text boxes and this phenomenom occurs in brand new files that only have text.

    David

  5. #5
    Star Lounger
    Join Date
    Jan 2002
    Posts
    74
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Re: Spell check in non-existent text boxes (Word2000/SP3)

    Thanks for writing.

    The phenomenom occurs even on brand new documents. But I decided to run the macro anyway, just in case. Didn't help. But I appreciate your help.

    Rgds,


    David

  6. #6
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spell check in non-existent text boxes (Word2000/SP3)

    Hi David:
    Maybe there's something in normal.dot or an add-in. Why don't you try the steps in <post#=197827>post 197827</post#>?
    Hope this helps,

  7. #7
    Super Moderator
    Join Date
    May 2002
    Location
    Canberra, Australian Capital Territory, Australia
    Posts
    5,054
    Thanks
    2
    Thanked 417 Times in 346 Posts

    Re: Spell check in non-existent text boxes (Word2000/SP3)

    Hi David,

    the text boxes ccould also be lurking in headers/footers, in which case tou need a more extensive macro:
    <pre>Sub DeleteAllTextBoxes()
    Dim TB As Shape
    Dim oSection As Section
    Dim oHeadFoot As HeaderFooter
    For Each TB In ActiveDocument.Shapes
    If TB.Type = msoTextBox Then TB.Delete
    Next 'TB
    For Each oSection In ActiveDocument.Sections
    For Each oHeadFoot In oSection.Footers
    For Each TB In oHeadFoot.Shapes
    If TB.Type = msoTextBox Then TB.Delete
    Next 'TB
    Next 'oHeadFoot
    For Each oHeadFoot In oSection.Headers
    For Each TB In oHeadFoot.Shapes
    If TB.Type = msoTextBox Then TB.Delete
    Next 'TB
    Next 'oHeadFoot
    Next 'oSection
    End Sub
    </pre>

    cheers
    Cheers,

    Paul Edstein
    [MS MVP - Word]

  8. #8
    Star Lounger
    Join Date
    Jan 2002
    Posts
    74
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Re: Spell check in non-existent text boxes (Word2000/SP3)

    I am now 99% sure why this happened.

    I edited the default settings of the Text Box in normal.dot. When I saved the template I must have left an empty text box open. Thenceforth, every document I created with the template had am empty non-visible text box for which Word insisted on checking the spelling.

    I have now re-edited the template and the problem no longer occurs.


    Thanks to all those who wrote with ideas.


    David

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •