Results 1 to 8 of 8
  1. #1
    2 Star Lounger
    Join Date
    Apr 2002
    Location
    Amersfoort, Utrecht, Netherlands
    Posts
    116
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Wrong sorting om Mailmerge (WD 97 SR2 Win 98 SP 2)

    Hello All,

    I have a weired situatuion...
    I have a large Word table with address customer information.
    Williams 2345 VD Amesterdam
    Jansen 3454 BG Groningen
    Vlaaminck B 5423 Brussels
    Hiro 4334 JN Rotterdam
    Gorkum 5123 VD Den Haag
    de Jong 5521 HN Rijswijk

    You see that there is also a Belgium address.

    When I mailmerge his table in a new document and set the query to sort on the postalcode field something strange happens:
    Williams 2345 VD Amesterdam
    Jansen 3454 BG Groningen
    Hiro 4334 JN Rotterdam
    Gorkum 5123 VD Den Haag
    Vlaaminck B 5423 Brussels
    de Jong 5521 HN Rijswijk

    This is wrong... but when I close the created document and try it again (so I changed notting in the merge options), the following list is created:
    Williams 2345 VD Amesterdam
    Jansen 3454 BG Groningen
    Hiro 4334 JN Rotterdam
    Gorkum 5123 VD Den Haag
    de Jong 5521 HN Rijswijk
    Vlaaminck B 5423 Brussels

    And that's How it should be!


    Do you have an explenation for this?

  2. #2
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong sorting om Mailmerge (WD 97 SR2 Win 98 SP 2)

    Hi Patrick:
    I am not sure I can help, but I don't fully understand the question. You said that when you "close the created document & try again" it works. I'm not sure what the created document is. Are you talking about the main document (the one with the merge fields) or the merged document (the result) or the datasource? Also, I don't see any postal code fields. Are you saying that you always have to run the merge twice to get it to work, or that this happened on one ocassion?

  3. #3
    2 Star Lounger
    Join Date
    Apr 2002
    Location
    Amersfoort, Utrecht, Netherlands
    Posts
    116
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong sorting om Mailmerge (WD 97 SR2 Win 98 SP 2)

    Hi Phil,

    Yes.
    I have to run the merge twice to get it right.
    So after creating the mergedocument (result) I close that one and run the merge again to create the correct one
    (btw, the postalcode field consist in this list of the postalcode and city name like '1234 HB Amsterdam' or 'B 1234 Brussels')

  4. #4
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong sorting om Mailmerge (WD 97 SR2 Win 98 SP 2)

    Hi Patrick:
    When you sort on the postal code in the query, it seems to me that the first sort order (that you say is wrong) is actually correct. If I look at this, it's sorted in numerical order. I assume that you're using the mail merge helper/query options/sort records & then choosing postal code. What's confusing is why you would get a different order the second time without making any changes. If some of the postal codes start with a number & some a letter, I would think that the numbers would be sorted first.

  5. #5
    2 Star Lounger
    Join Date
    Apr 2002
    Location
    Amersfoort, Utrecht, Netherlands
    Posts
    116
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong sorting om Mailmerge (WD 97 SR2 Win 98 SP 2)

    Okay..

    Check this...

    I can sent you the Word file to test it...

    > Create a new document
    > Mailmerge
    > Current document, catalog
    > Datafile is the attached file
    > Set up the document
    > Make a table of tree coloms, one row
    > First cel : ACHTERNAAM
    > Second cel : VOORNAAM
    > Third cel : BEZOEK_POSTCODE_WOONPLAATS
    > Reopen mailmerge window
    > Set query/sort options
    > Sort on BEZOEK_POSTCODE_WOONPLAATS
    > Create merge to new document

    You will see now that the third colomn is incorrect sorted
    Close the created document en reopen the merge window
    > Open the query/sort window
    > Look at the sort options, but don't change anything
    > Create a new merge to new docuemt and see that the column is correctly sorted

    I hope it will work..... but why?

  6. #6
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong sorting om Mailmerge (WD 97 SR2 Win 98 SP 2)

    Hi Patrick:
    I would be willing to test this if you want to send me the file. However, I have Word 2000 & not Word 97. Still, I could play around with it.

  7. #7
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong sorting om Mailmerge (WD 97 SR2 Win 98 SP 2)

    Hi Patrick:
    I've received your file. It's quite large, with over 2700 pages. Nevertheless, I was able to duplicate the problem in Word 2000. I only merged the first 100 records. It just seems to me to be a bug. First of all, I should say that I inserted & sorted by
    { MERGEFIELD SORTEER_POSTCODE }
    which is listed as BEZOEK_POSTCODE_PLAATS rather than BEZOEK_POSTCODE_WOONPLAATS.

    The only thing I could think of is that the first time Word sorted, it sorted by number. This would make sense since MOST of the codes start with numbers. The B for Brussels was ignored & the numbers after it were sorted, just as if the B didn't exist. If you take the resultant table (merged document) & sort the 3rd column by number, you get the same incorrect result. However, if you do Table/Sort & sort the 3rd column by text, you get the correct result.

    By the way, it has nothing to do with closing the merged document. Also, if you merge several times, you get the same incorrect sort each time. It's only if you go to query options, open the dialog box, & click OK (even without making changes), that it sorts correctly the second time. From then on, even if I cleared all sorting & then set the query options again, it sorted correctly.

    I also found that if I first sorted the datasource by BEZOEK_POSTCODE_PLAATS as text, then I could correctly sort by mail merge query options the very first time. I know that this is not a solution. What it means is that you must set the query options, click OK & then go back in & click OK again for the correct sort order. Doesn't give you a lot of confidence.

    After playing around with this for an hour, I finally did what I should have done before. I went to the MS knowledge base & found Mail Merge Query Options Fail with Mixed Text and Numbers. So I guess we both proved it. <img src=/S/flatcat.gif border=0 alt=flatcat width=61 height=21> Their workaround is to use MS Access & do the query there.
    Cheers,

  8. #8
    2 Star Lounger
    Join Date
    Apr 2002
    Location
    Amersfoort, Utrecht, Netherlands
    Posts
    116
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong sorting om Mailmerge (WD 97 SR2 Win 98 SP 2)

    Great Phil,

    I searched the knowlae base but did not found....
    I'm happy to know it is a known bug, and we had told the uses to use Access when the file gets this big.
    But you know how users are.....
    Thanks again for looking in to this problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •