Results 1 to 7 of 7
  1. #1
    2 Star Lounger
    Join Date
    Oct 2001
    Location
    Canberra, Australian Capital Territory, Australia
    Posts
    136
    Thanks
    0
    Thanked 0 Times in 0 Posts

    AutoText (Word 2000)

    Hello Word Gurus.

    Is there any setting I can disable to stop Word automatically putting in an extra space after AutoText entries that I have defined. For example, I have created an AutoText entry to insert NAME) with a space included after the ")" character. However, when I go to use this entry, there is an extra space inserted automatically when I start typing! So I end up with 2 spaces. I have tried creating another entry without the space, however when inserted it displays no space until you start typing!

    Looking forward to a response.

    Cheers,

    Jocelyn

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: AutoText (Word 2000)

    Interesting phenomenon. It turns out to be related to whether an AutoComplete suggestion is displayed
    <UL><LI>If "Show AutoComplete suggestions" is off, Word doesn't add an extra space when you press F3 to insert the AutoText fragment and continue typing.
    <LI>If "Show AutoComplete suggestions" is on:
    <UL><LI>If the name of the AutoText entry is less than four characters in length, no AutoComplete suggestion is displayed. When you press F3 to insert the AutoText entry and continue typing, no extra space is added.
    <LI>If the name of the AutoText entry is at least four characters long, Word displays an AutoComplete suggestion. When you press F3 or Enter to insert the AutoText entry and continue typing, an extra space is added.[/list][/list]So to avoid the extra space, turn off "Show AutoComplete suggestions" or give your AutoText entry a name of less than four characters.

  3. #3
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: AutoText (Word 2000)

    Nice find, Hans. I suppose an alternative is to have AutoComplete on, have the name more than 4 letters, create the entry without a space on the end. It will automatically put in a space when you type. Not intuitive, but it works.

  4. #4
    2 Star Lounger
    Join Date
    Oct 2001
    Location
    Canberra, Australian Capital Territory, Australia
    Posts
    136
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: AutoText (Word 2000)

    Thanks kindly for your response.

    Word is a frustrating beast!

    Cheers,

    Jocelyn

  5. #5
    New Lounger
    Join Date
    Oct 2003
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: AutoText (Word 2000)

    Is there any way to access AutoText entries (Word 97/2000) programmatically (that is, through VBA) or any other way than the menus? I'm having serious problems keeping the formatting on this AutoText entry I need to change.

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: AutoText (Word 2000)

    AutoText entries are exposed in the Word object model. In the Visual Basic Editor, activate the object browser (F2) and type autotext into the search box, then press Enter. You''ll see a list of items related to AutoText. To get help on an item, click on it and press F1.

  7. #7
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: AutoText (Word 2000)

    This sounds as though perhaps it should be a new thread. Could you explain the problem in more detail? You can programmatically change the content of an AutoText entry, but in a recent test (see <post#=300167>post 300167</post#>), I found that this trashed the original style information. Your mileage may vary.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •