Results 1 to 8 of 8
  1. #1
    jzanieski
    Guest

    Open Word 2000 documents in Word 97

    Does anyone know if there is a way to PREVENT a user from opening a Word 2000 document in Word 97? There are some compatibility issues that we would like to avoid.

  2. #2
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open Word 2000 documents in Word 97

    I'm going to venture a guess that you can't do it directly. Other than using profiles to restrict a user or users from accessing a folder or file, I don't see how you could. MS has tried to make it's files backward compatible.

    If the users are cooperative, you could password protect all Word 2000 documents & then tell users who have Word 97 not to open documents that require a password. To do so, you might change the FileSaveAs command in normal.dot on Word 2000 machines to always require a password, but this might create more problems than it solves.

  3. #3
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open Word 2000 documents in Word 97

    Would this do?
    <pre>Private Sub Document_Open()
    If Application.Version <> "9.0" Then ActiveDocument.Close
    End Sub
    </pre>

    (Macros need to be enabled)

  4. #4
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Open Word 2000 documents in Word 97

    Well, I'm going to stop underestimating VBA. <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

  5. #5
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Open Word 2000 documents in Word 97

    I would be loathe to add macros to every document and desensitize users to the risks of opening documents containing macros.

    How about adding a custom property to the documents when created or saved, something like "Word2000" with a value of Yes or No. You could check this upon opening and inform the user that the document should not be edited in Word97. The code could reside in the templates on both ends, and no scary stuff in the document.

    This doesn't really address the real issue, though, of detecting the version in which the document itself was saved. Chris Greaves posted some code on the VBA board which actually peeks at the beginning of the file. Whether it could differentiate the particular flavor of Word format, i don't recall.
    Attached Images Attached Images

  6. #6
    BAM
    Guest

    Re: Open Word 2000 documents in Word 97

    Perhaps you could expand on the compatibility issues you want to avoid. I can think of only a few that would change the look of the document and there are work-arounds for most of them.
    ~~~~~~~~~~~~~~
    Cheers!

  7. #7
    jzanieski
    Guest

    Re: Open Word 2000 documents in Word 97

    When you open a Word 2000 document in Word 97, the compatibility options are set to custom. You then work on the document and then save it in Word 97. Another user would work on the document in Word 2000. The compatibility options again are set to Word 97 even though you are working in Word 2000. We are going through a migration where there is a good chance some people would work on documents that are now Word 2000 even though they are still on Word 97.

  8. #8
    BAM
    Guest

    Re: Open Word 2000 documents in Word 97

    Hi jzanieski,

    This really shouldn't be a problem. The Word 2000 and Word 97 file formats are compatible. If someone does use a feature that isn't available in Word 97 it can still be opened.

    If there aren't any specific compatibility issues, then in a multi-version environment it is recommended that on the Word 2000 workstations in Tools/Options/Save to turn on "Disable features not in Word 97" and make sure that "Fast Saves" is turned off.
    ~~~~~~~~~~~~
    Cheers!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •