Results 1 to 3 of 3
  1. #1
    Gesine
    Guest

    The file is so big

    [img]/w3timages/icons/crazy.gif[/img]I have recently upgraded from Access 97 to Access 2000 and written a database to be used in my office. Problem is that the database is HUGE (11 MB without any actual data), although a database with that level of complexity used to be max 4-5 MB in Access 97. Repair & compact does not help. Is there any other way ?
    tks for suggestions
    brgds Gesine

  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: The file is so big

    Part of the difference is that Access 2000 uses Unicode. However, there are a few things you can do to bring the size down somewhat.

    First, go to Tools-->Options-->General and turn off all the Name Autocorrect options. Not only is it implicated in a lot of screwy problems in Access, but it bloats the database at the same time! Unfortunately, this is on by default and is database-specific, so you have to change the setting on each new database.

    Next, go through your tables and turn off the subdatasheet property by setting it to [none] where it is set to something else. Since this is a converted database, you should only see subdatasheets turned on for tables you created in the new version, but check just in case. This is another of those ideas that looks good if you don't examine it too closely. In fact, subdatasheets are queries, and their existence in a table that you use in a query just adds overhead without offering any benefits. Since you don't let users look at tables anyhow (you don't, right?), you don't need subdatasheets. To turn them off, open a table in design view (if it's a linked table, you have to do this in the backend) and open the properties dialog. You'll see the subdatasheet property, probably set to [Auto]. Change it to [none]. Oh, and they're on by default on any new table you create, so get used to turning them off.

    One thing I've noticed in this version is that it will refuse to compact any further sometimes and there is no option but to create a new database and import the objects from the old one. That apparently gets rid of some of the temporary system stuff that Access seems to hang onto and lets you start clean. When one of mine won't compact down to the size it should be, that's the only cure I've found.
    Charlotte

  3. #3
    4 Star Lounger SteveH's Avatar
    Join Date
    Jan 2001
    Location
    Chelsea, Gtr London, United Kingdom
    Posts
    587
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: The file is so big

    I found that decompiling the database (Access2000) cut the file size by about half (10MB to 5MB). It grew again over time as I tinkered with it but it was leaner and meaner for a time. This was the very useful article which I used for reference
    http://www.trigeminal.com/usenet/usenet004.asp?1033
    I have not had a problem with it (in fact it mended a database of mine for me!) but the usual caveats apply.
    Hope this helps.
    Steve H
    IT Lecturer/Access Developer
    O2K SR3/O2010; Win7Pro

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •