I've just been upgraded to Outlook 2003 (which by the way I find excellent). The Junk E-Mail program works very well except that when I right-click on the Junk e-mail folder, and choose mark all as read, it doesn't work. Is there a setting I need to tick on this? Mark all as read works on all my other folders.

Thanks for any help.