Results 1 to 8 of 8
  1. #1
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Quedgeley, Gloucester, England
    Posts
    5,333
    Thanks
    0
    Thanked 1 Time in 1 Post

    Can't get rid of 'Language bar' toolbar (XP any)

    If I get rid of the tick in front of "Language bar" in the Toolbars, the "EN" icon in what used to be called the System Tray at the bottom right-hand-side of the screen goes away. Until I reboot, or log off/on. Then it comes back again!

    Is there any way to stop the icon returning? It's just a small annoyance...!
    <font face="Script MT Bold"><font color=blue><big><big>John</big></big></font color=blue></font face=script>

    Ita, esto, quidcumque...

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Can't get rid of 'Language bar' toolbar (XP any)

    Try Start | Settings
    Click Date, Time, Language and Regional Options (if you use Category View) then Regional and Language options.
    Activate the Languages tab.
    Click Details...
    Activate the Settings tab (if necessary)
    Click Language Bar...
    Make sure that the "Show the Language bar on the desktop" and "Show additional Language bar icons in the taskbar" check boxes are clear.
    OK your way out.

  3. #3
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Quedgeley, Gloucester, England
    Posts
    5,333
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Can't get rid of 'Language bar' toolbar (XP any)

    Thanks, Hans, there was previously a tick in the "Show the language bar on the desktop"!
    <font face="Script MT Bold"><font color=blue><big><big>John</big></big></font color=blue></font face=script>

    Ita, esto, quidcumque...

  4. #4
    2 Star Lounger
    Join Date
    Sep 2001
    Location
    Kalgoorlie, Western Australia, Australia
    Posts
    155
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Can't get rid of 'Language bar' toolbar (XP any)

    I am trying to make my language bar appear - but the language bar button is greyed out.

    Any suggestions?

  5. #5
    Gold Lounger Rebel's Avatar
    Join Date
    Jul 2001
    Location
    Canada
    Posts
    3,024
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Can't get rid of 'Language bar' toolbar (XP any)

    Melissa,
    Go to the Advanced tab in the Text Services and Input Languages screen and make sure that "Turn off advanced text services" is unchecked. If this is checked, the language bar is disabled. You can also view whether or not this "service" is running by using msconfig. If "ctfmon.exe" is shown in "Startup", the language bar is running. If it has been unchecked, it is not running.
    John
    A Child's Mind, Once Stretched by Imagination...
    Never Regains Its Original Dimensions

  6. #6
    2 Star Lounger
    Join Date
    Sep 2001
    Location
    Kalgoorlie, Western Australia, Australia
    Posts
    155
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Can't get rid of 'Language bar' toolbar (XP any)

    Thanks for that - "Turn off advanced text services" is unchecked I tried turning it off & on again - no change.

    ctfmon.exe is not listed on msconfig - cthelper.exe is
    Also, there is now no language bar listed when I right-click the taskbar.

  7. #7
    Gold Lounger Rebel's Avatar
    Join Date
    Jul 2001
    Location
    Canada
    Posts
    3,024
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Can't get rid of 'Language bar' toolbar (XP any)

    Cthelper is Sound Blaster related. Leave "Turn off advanced text services" unchecked and try copying ctfmon.exe (Windows/System32 folder) to your Startup folder and see if this resolves the problem. If not, then you may have a corrupt file. If this is the case, sfc /scannow may be the solution.
    John
    A Child's Mind, Once Stretched by Imagination...
    Never Regains Its Original Dimensions

  8. #8
    2 Star Lounger
    Join Date
    Sep 2001
    Location
    Kalgoorlie, Western Australia, Australia
    Posts
    155
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Can't get rid of 'Language bar' toolbar (XP any)

    Well I have managed to fix the problem.

    What happened was that I had accidentally deleted "English (United States) Keyboard US" from the Installed Services List while still having "English (United States) - US" as the Default Input Language. (Though looking at my earlier screenshot that wasn't the case! Hmmm, something weird is going on!)

    This means that the language settings were confusing themselves because the default input language was not one of the installed services.

    I fixed the problem by reinstalling "English (United States) Keyboard US" and then changing the Default Input Language to "English (Australia) - US"

    Hooray!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •