Results 1 to 7 of 7
  1. #1
    elin
    Guest

    Remove automatic hyperlinks

    I can't stand the fact that Excel 2001 (mac) is automatically formatting any text string with an "@" as an email address. Editing typos in those fields is extra exciting when clicking on the cell launches Outlook for me. I have looked high and low and cannot figure out how to turn this off. Please, please help me, before I perform an emergency defenestration.

  2. #2
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Dublin, Ireland, Republic of
    Posts
    2,697
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: Remove automatic hyperlinks

    If you precede the text in question with ' (single quote) it is treated like any other text. The ' character does not display. You can also right click on the text and select Remove Hyperlink.
    Both of these methods work in XL2000 for Windows.

    Andrew C

  3. #3
    elin
    Guest

    Re: Remove automatic hyperlinks

    For some reason, the single quote trick does not work on the mac, and of course there is no right click on a mac. I can turn off individual hyperlinks by sneaking up on the neighboring cell, entering the cell with the arrow keys, selecting "Insert.. Hyperlink" from the menu, and clicking remove. Unfortunately, with an imported 500 line data file this is not a satisfying solution.

    I would be happy to set Excel to never launch any other application for any reason ever, if that would solve it. Is that possible?

  4. #4
    2 Star Lounger
    Join Date
    Dec 2000
    Posts
    120
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Remove automatic hyperlinks

    Well, you could delete them all at once using something like:

    Selection.Hyperlinks.Delete

  5. #5
    4 Star Lounger
    Join Date
    Mar 2001
    Location
    Bismarck, ND, USA
    Posts
    451
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Remove automatic hyperlinks

    The automatic formatting is coming from a Style. If you don't want the automatic formatting, you can modify the style. Use Format, Style, and choose the Style Hyperlink. Clear the check mark from Font, and it will no longer create hyperlinks.

    You could also delete the Style altogether.
    egghead

  6. #6
    von
    Guest

    Re: Remove automatic hyperlinks

    Tried the "uncheck style" idea, but it didn't work. Does anyone know how to stop http and email addresses from autoformatting?? The "remove hyperlink" is too onerous if you have a lot of links to remove.

    Thanks.

    Von

  7. #7
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Sydney, Australia, New South Wales, Australia
    Posts
    251
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: Remove automatic hyperlinks

    This only removes the underline from the style; it doesn't stop it *being* a hyperlink. Removing or changing a style only changes the appearance of cells in that style.
    The only way I've found to overcome this is to start the cell with a space or apostrophe '. That stops it being a hyperlink, and therefore stops it looking like a hyperlink as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •