Results 1 to 4 of 4
  1. #1
    5 Star Lounger st3333ve's Avatar
    Join Date
    May 2003
    Location
    Los Angeles, California, USA
    Posts
    705
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Access is filling in numbers in table (A2002 (SP-2))

    I hope this is an easy one, but I'm stumped.

    I'm entering some data directly into a Number (Integer) field in a table. If I put 75 in one row and 76 in the next row and then move to the next row, Access helpfully (NOT!) fills in 77 for me. Likewise if I put 64 in one row and 66 in the next row, Access automatically puts 68 in the next row when I move to it.

    What is this wonderful feature called, and how do I turn it off?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Access is filling in numbers in table (A2002 (SP-2))

    It's called AutoFill and you can't turn it off, except by setting a Default Value for all your fields. <img src=/S/yikes.gif border=0 alt=yikes width=15 height=15> Microsoft thinks it's good for you!

    See ACC2000: Tables Are Automatically Populated with Values As You Move Through Fields or Records for a description.

    See this Newsgroup thread for the bad news, straight from Microsoft.

  3. #3
    5 Star Lounger st3333ve's Avatar
    Join Date
    May 2003
    Location
    Los Angeles, California, USA
    Posts
    705
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Re: Access is filling in numbers in table (A2002 (SP-2))

    <img src=/S/bash.gif border=0 alt=bash width=35 height=39> Thanks for the quick response. (And I note that setting the Default Value to Null doesn't do the trick.)

    One more reason to pine for the Big Breakup, I guess.

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Access is filling in numbers in table (A2002 (SP-2))

    Null is nothing, blank, empty, so setting the default value to Null doesn't mean anything. If you want to avoid AutoFill, you must set the default value to something, not to nothing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •