Results 1 to 5 of 5

Thread: Read Only (XP)

  1. #1
    3 Star Lounger
    Join Date
    Dec 2000
    Location
    Ohio - USA, Ohio, USA
    Posts
    294
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Read Only (XP)

    I converted a 2000 database to XP and now receive a message when I open it that it is "read only" (even though it never was before). Then when I try to make changes, I (obviously) cannot save them.

    How do I take away the read only status so I can use this thing before.

    How strange that in all the years I've worked with Access this has never happened (to me) before.

    Thank s.


    CD

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Read Only (XP)

    Try the following:
    - Start Access, but don't open the Access 2000 database.
    - Select Tools | Database Utilities | Convert Database | To Access 2002 File Format...
    - In the "Database to Convert From" dialog, select the Access 2000 database
    - Click Convert.
    - Specify a different name or different location (or both) for the converted database.
    - Click Save.
    - Click OK to the message that you won't be able to share the database with Access 2000 or Access 97 users.

    Post back if this doesn't help.

  3. #3
    3 Star Lounger
    Join Date
    Dec 2000
    Location
    Ohio - USA, Ohio, USA
    Posts
    294
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Read Only (XP)

    Thanks very much, HansV, that worked very well. Of course, because this particular db is huge (4 meg) I backed it up to a CD and then get the same "read only" message when opening it from the CD. So, I will just repeat the process when I move this from my computer to the clients.

    Thanks again.


    CD

  4. #4
    Lounger
    Join Date
    Jan 2004
    Location
    Derry, Derry, Ireland, Northern
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Read Only (XP)

    Hi,

    Not sure how the original problem got there but one other cure is to right click on the file in Windows explorer (without opening it) and choose "Properties" - at the bottom of the "General" tab you will see a check box for the 'Read only' attribute - remove the check. Click OK and retry the opening of the file.

    Also, when you copy ANY file to CD and then back to hard disk, the file is, by default, Read only (since CD ROMs typically cannot write to a CD), and the quickest solution is to uncheck the read only property, as above.

    Regards

  5. #5
    3 Star Lounger
    Join Date
    Dec 2000
    Location
    Ohio - USA, Ohio, USA
    Posts
    294
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Read Only (XP)

    Thanks very much for the great suggestions!

    CD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •