Results 1 to 3 of 3
  1. #1

    Subform troubles

    <img src=/S/salute.gif border=0 alt=salute width=15 height=20>Hello helpers,
    I'm still writing this first ever database of mine. I have a subform on one of my main forms which displays the history of the entity displayed on the main form (dates entity amended and reason for amendment etc)it picks up the info from a query. Sometimes this works beautifully but a lot of the time the subform will display the history from the last record I looked at rather than the current one. How do I stop it doing this please? (the database is supposed to be going live company wide at the end of April)

  2. #2
    4 Star Lounger
    Join Date
    Dec 2000
    London, Ontario, Canada
    Thanked 0 Times in 0 Posts

    Re: Subform troubles

    Hello Penn:
    If you are moving from record to record using a command button, you may need to issue a .Requery command in the code behind the button.
    Best of luck with your end of April deployment. <img src=/S/smile.gif border=0 alt=smile width=15 height=15>

  3. #3

    Re: Subform troubles

    Cheers Brian,

    I've added a requery and it works beautifully all the time now <img src=/S/cheers.gif border=0 alt=cheers width=30 height=16>. Just got to work my way through the rest of it before the end of the month! Watch out for more beginner questions.

    Thanks a lot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts