Results 1 to 6 of 6
  1. #1
    Star Lounger
    Join Date
    Apr 2003
    Location
    Edinburgh, Midlothian, United Kingdom
    Posts
    93
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Autocomplete Dates (Word 2000)

    Some of our machines have been upgraded to Word 2000. In 97 when you started typing a date the autocomplete tip would come up and you could hit return and the date would come in as "23 January 2004". In Word 2000 the tip comes up and you hit return but you only get "23 Jan. 2004".

    How can I change the date format for this?

    Have tried changing the default in Insert - Date and Time but that didnt work.

    Thanks

  2. #2
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Autocomplete Dates (Word 2000)

    Hi Carolyn:
    This is controlled by the setting: Control Panel/Regional Settings/Date tab. Check the format that is set for the long date (& short one too, if you want). This will be the format that Word will use for AutoComplete.
    Hope this helps,

  3. #3
    Star Lounger
    Join Date
    Apr 2003
    Location
    Edinburgh, Midlothian, United Kingdom
    Posts
    93
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Autocomplete Dates (Word 2000)

    Hi Phil
    Tried that - the settings in there are set how I want them to look - but its still bringing in 26 Jan. 04 - have you any other ideas?

  4. #4
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Autocomplete Dates (Word 2000)

    Hi Carolyn:
    That's surprising. 2 things to check. In Control Panel/Regional settings, check the date separator. Also, I'd change the Regional Setting, apply the change, reboot, then change it back again. Sometimes, a setting doesn't stick.

    Other than that, make sure that you don't have any special autotext entries for the date. Try following the steps in <post#=197827>post 197827</post#>, if that doesn't help. After that, I'm not sure. The default date format is contained in the registry at

    HKEY_CURRENT_USERSoftwareMicrosoftOffice9.0WordOpt ionsDefaultDateFormat

    However, it's in binary form. What format do you get if you simply enter a field: {DATE} & then press F9, where the curly braces are inserted by pressing Ctrl+F9, not typed?

  5. #5
    Platinum Lounger
    Join Date
    Jan 2001
    Posts
    3,788
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Autocomplete Dates (Word 2000)

    For info I get the same result as Carolyn but using Word 2003.

    All regional settings set to English(UK) with short date format dd/MM/yyyy and long date format dd MMMM yyyy.

    There are no autotext entires for dates and {DATE} results in the long date format. This only comes up with that format since I changed the default setting by selecting "Insert>Date and Time...", choosing the relevant format and clicking on default. It used to show the short date format by default.

    Finally I checked the registry and the DefaultDateFormat key does not exist for Office 11 (did a complete search of the registry for the key)

    Still this is one feature I did not use as I use date field on all templates.

  6. #6
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Autocomplete Dates (Word 2000)

    Thanks, Tony. Maybe something is different when the language is set to English (UK)?? The only thing I could find in the MS KB was:

    WD2000: Cannot Change Suggested AutoComplete Date Year Format and
    WD2000: Default Date Format Is Not Selected Switching Languages. The first article says that the problem was corrected with SR-1a (in Word 2000). Carolyn, if you're reading this, do you have the service releases installed?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •