Results 1 to 12 of 12
  1. #1
    3 Star Lounger
    Join Date
    Jan 2004
    Location
    Birmingham, West Midlands, United Kingdom
    Posts
    219
    Thanks
    0
    Thanked 0 Times in 0 Posts

    hyperlink, unwanted web toolbar (XLXP)

    I have set up a hyperlink from one workbook to open a different workbook and go to a specified address. This works fine, but the target workbook is opened with the web toolbar displayed.
    I didn't ask for this.
    How do I suppress it?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: hyperlink, unwanted web toolbar (XLXP)

    This is a "feature" of Office programs. You can disable the web toolbar as follows:
    - Switch to the Visual Basic Editor (Alt+F11)
    - Activate the Immediate window (Ctrl+G)
    - Type Application.CommandBars("Web").Enabled = False then press Enter.
    - Switch back to Excel.
    You should only have to do this once. If you ever want to enable the web toolbar again, repeat the above with ... = True instead of ... = False.

  3. #3
    3 Star Lounger
    Join Date
    Jan 2004
    Location
    Birmingham, West Midlands, United Kingdom
    Posts
    219
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: hyperlink, unwanted web toolbar (XLXP)

    Where, Hans?
    Having done what you described (I think!), the contents of the Immediate window are:

    [auto_open] <
    [SetupFunctionIDs] <
    [SetupFunctionIDs] >
    [PickPlatform] <
    [PickPlatform] >
    [VerifyOpen] <
    [VerifyOpen] > 1
    [RegisterFunctionIDs] <
    [RegisterFunctionIDs] >
    [auto_open] >
    Application.CommandBars("Web").Enabled = False

    Regretfully, this has not suppressed the feature.
    Sorry if I'm thick.

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: hyperlink, unwanted web toolbar (XLXP)

    The first lines are debug information from loading the Analysis Toolpak (or its VBA counterpart), you can ignore or delete them.
    Just to make sure, click anywhere in the line
    Application.Commandbars("Web").Enabled=False
    Then press Enter. If that doesn't help, I don't know, sorry.

  5. #5
    2 Star Lounger
    Join Date
    Sep 2002
    Location
    Birmingham, England
    Posts
    123
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: hyperlink, unwanted web toolbar (XLXP)

    Thanks, Hans, that works ok on different machine, here, where there was nothing in the Immediate window.
    Will do your remedy on home box tonight.
    (How do you and the other gurus find out this arcane sort of stuff?)

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: hyperlink, unwanted web toolbar (XLXP)

    >> How do you and the other gurus find out this arcane sort of stuff?

    By visiting Woody's Lounge, of course <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

    (and by searching the Microsoft Newsgroups, the MVP site, John Walkenbach's site, Chip Pearson's site etc., and last but not least by experimenting.)

  7. #7
    3 Star Lounger
    Join Date
    Jan 2004
    Location
    Birmingham, West Midlands, United Kingdom
    Posts
    219
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: hyperlink, unwanted web toolbar (XLXP)

    And works ok on the other one, too, having rubbed out existing stuff.
    Thanks again.

  8. #8
    3 Star Lounger
    Join Date
    Jul 2001
    Location
    Florida, USA
    Posts
    394
    Thanks
    0
    Thanked 0 Times in 0 Posts
    [quote name='HansV' post='341024' date='09-Feb-2004 01:37']This is a "feature" of Office programs. You can disable the web toolbar as follows:
    - Switch to the Visual Basic Editor (Alt+F11)
    - Activate the Immediate window (Ctrl+G)
    - Type Application.CommandBars("Web").Enabled = False then press Enter.
    - Switch back to Excel.
    You should only have to do this once. If you ever want to enable the web toolbar again, repeat the above with ... = True instead of ... = False.[/quote]

    Hi Hans,
    I had the same problem. This worked great at home, but didn't make any difference at work. At work, the Excel program (2003) is on a Wan (along with all the spreadsheets), wonder if that makes a difference. Since you have to logon to the Wan, it does keep my special toolbars and macros the way I set them up though.

    The only thing currently under "Immediate" is the "Application.CommandBars("Web").Enabled = False" that I entered.

    Any other ideas?

    Thanks
    Louise

  9. #9
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    Do you have a personal macro workbook Personal.xls of your own? If not, it'll be difficult.

  10. #10
    3 Star Lounger
    Join Date
    Jul 2001
    Location
    Florida, USA
    Posts
    394
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hans,

    Yes I do. My toolbar has icons that activate macros in the Personal.xls.
    Louise

  11. #11
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    Try the following:

    - Start Excel.
    - Press Alt+F11 to activate the Visual Basic Editor.
    - Double-click the ThisWorkbook node under Personal.xls in the project explorer on the left hand side.
    - Copy the following code into the module that appears:

    Private Sub Workbook_Open()
    Application.CommandBars("Web").Enabled = False
    End Sub

    - This code will run automatically each time you start Excel.

  12. #12
    3 Star Lounger
    Join Date
    Jul 2001
    Location
    Florida, USA
    Posts
    394
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Hans,

    Once again you've worked miracles. Worked perfectly.

    Thanks so much.
    Louise

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •