Results 1 to 11 of 11
  1. #1
    3 Star Lounger
    Join Date
    Oct 2001
    Location
    Newport, Gwent, Wales
    Posts
    257
    Thanks
    0
    Thanked 0 Times in 0 Posts

    CD-ROM missing after install (XP Pro)

    Dear All

    I've been trying to install XP Pro on my home PC for some time now and had the same problem continuosly. Once the OS is installed from teh CD-ROM it reboots and fails to detect the CD-ROM it was installed from. Now this appears to be a common problem as the MSKB has a solution for it that involves chaning registery settings, except this doesn't work on my PC...

    So, what else should be doing?

    Thanks

    Ian

  2. #2
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: CD-ROM missing after install (XP Pro)

    Ian,

    Is the CD ROM being detected by your system?
    Look in Device Manager to see and also try to check for updates to the CDROM drivers.

    Bob
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  3. #3
    3 Star Lounger
    Join Date
    Oct 2001
    Location
    Newport, Gwent, Wales
    Posts
    257
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: CD-ROM missing after install (XP Pro)

    Bob

    OK, should have given a bit more detail.....

    Nope, the CD-ROM isn't being detected by the system, it's a Lite-On CD rewriter, the site claims no driver is required, the MSKB agrees with this.

    The MSKB fix refers to a registry entry which, on my PC has no values in it at all. The fix says to delete Value X........

    Thanks

    Ian

  4. #4
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: CD-ROM missing after install (XP Pro)

    Ian,

    If the system isn't seeing ( detecting ) the CDROM, then your BIOS must be set wrong. If the OS isn't detecting it but the BIOS is, that's another story.
    Has this drive been working before with another OS?
    How do you have it set up, mechanically? As a slave to the primary HD or on it's own PCI slot, primary or secondary?
    This is the type of info we need to get further into the problem.

    Bob
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  5. #5
    3 Star Lounger
    Join Date
    Oct 2001
    Location
    Newport, Gwent, Wales
    Posts
    257
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: CD-ROM missing after install (XP Pro)

    Bob

    OK, my BIOS is detecting the CD-ROM, the same CD-ROM works fine with my current Win 98 set-up. I was thinking of the system as the whole thing, hardware and OS..... sorry.

    I've got the CD-ROM set-up as the master drive on the secondary HDD connection.

    The only thing I changed (fortunately) in order to install XP was the HDD, I bought myself a new one as I'd read it made things more reliable from the install point of view. As things worked out it menat I could refit the old HDD and get back to work.....

    The system BIOS reports the exact make and model of CD-ROM, same as it reports a HDD.

    The only other stuff I've got in the PC is a sound card, a basic Sound Blaster 16, a generic 56 kBit modem and my video card, another bit of Creative's work, the system reports it as a Creative GB0010.

    All this stuff works fine under Win 98.

    Thanks for the reply.

    Ian

  6. #6
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Seattle, Washington
    Posts
    320
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: CD-ROM missing after install (XP Pro)

    So are you unplugging the 98 hard drive and plugging in the new (XP) one? Should be set up like this:

    IDE 0 ("primary hard drive connection") Plug the new hard drive into the end plug on the 80 wire cable. Make sure that the hd jumper on the back of the drive is set to Master (or cable select - which will set the end plug as master)

    IDE 1 ("secondary hard drive connection") CD - set with jumpers to Master, plugged into the end plug of a second 80wire cable.

    Is this the way you are set up?

    kip

  7. #7
    3 Star Lounger
    Join Date
    Oct 2001
    Location
    Newport, Gwent, Wales
    Posts
    257
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: CD-ROM missing after install (XP Pro)

    Apologies for the delays in getting back to these, I'm using a few holiday days from last year, so not 'hooked up' to the PC as much as usual.

    Yup, both the new HDD and the old CD-ROM are set to master on the connections, HDD = master IDE 0, CD-ROM master = IDE 1.

    BIOS reports both as being the master drive on the relevant connection. Before it occurred to me to ask in here (I only usually use the Access forum...) I've tried almost every convceivable mix of drive connections in the vain idea that this might be the problem. This includes having the HDD as master on IDE 0 and the CD-ROM as slave on IDE 0, the HDD as master on 0 with the CD-ROM as slave on 1.

    Thanks

    Ian

  8. #8
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: CD-ROM missing after install (XP Pro)

    Ian,

    Just so that I get this straight in my mind, Your system is OK , except that the CD ROM is NOT being detected by the OS? If so,

    Try unplugging the CD ROM & booting without the CDROM in place. Shut down.
    Plug in the CDROM again and letting the system try to recognize it on ReBoot.
    If that fails, go to Control Panel>Add Hardware and run the add hardware wizard to see if you can manually show the way to your Drive.
    As long as the BIOS is seeing the proper CDROM info, it has to be a clash somewhere in the OS that is preventing proper install of the hardware.

    Bob
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  9. #9
    3 Star Lounger
    Join Date
    Oct 2001
    Location
    Newport, Gwent, Wales
    Posts
    257
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: CD-ROM missing after install (XP Pro)

    OK,Sorry to 'boing' this afer so long, but I'm still not on XP. The last did not help and I've had too much to do since to try any more suggestions.

    My latest attempt involved removing everything except the HDD, CD-ROM and the video card from the PC, installing from scratch (including a format) and then removing the CD-ROM, rebooting with the CD-Rom back in place. No change. XP does boot a lot more quickly without the CD in place, but as I've removed everything I can I don't see what else might be causing the problem.

    This is really starting to 'get my goat' now. I've had problems with MS operating systems before, but always been able to find the conflict and resolve it, one way or another. The frustration here is taking year off my life [img]/forums/images/smilies/smile.gif[/img]

    Ian

  10. #10
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: CD-ROM missing after install (XP Pro)

    Ian,


    Have you gone into Device Manager to see what it looks like in there? Any yellow flags to indicate a clash? Clicked on DVDCDROM drives to see if the proper CD ROM is shown there?

    Right click My Computer> click Advanced>Device Manager>DVD/CDROM.
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  11. #11
    3 Star Lounger
    Join Date
    Oct 2001
    Location
    Newport, Gwent, Wales
    Posts
    257
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: CD-ROM missing after install (XP Pro)

    I've been into the device manager and there's no sign of a DVD/CD ROM option.....

    No yellow question marks any where. The only time I managed tis was when I deleted the whole CD ROM section from the registry and went through the add new hardware wizard and added a CD ROM (It wont let you do this until the registry entry is deleted). This then gave me the Code 32 error, which referes to the uppler and lower filters in the registry, neither entry is there so I can't take the advice and delete them.....

    I'll drop the HDD back in tomorrow and have another look at the device manager, but I'm 90 percent certain there's no DVD reference in it...??

    Thanks

    Ian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •