Results 1 to 6 of 6
  1. #1
    Lounger
    Join Date
    Sep 2002
    Location
    Brookings, South Dakota, USA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Disappearing data (2002)

    I've had several instances of data disappearing. I also have a couple things going on at once. I have 2 databases in a frontend backend format on a server, 1 secured and 1 not. Recently several computers were upgraded from XP to 2003 so the databases were being opened in both versions of office. The other change is that we were moved to a new server using active X instead of novell. After 4 days I started hearing about the missing data. I'm not sure if I should put my backup on the server or if the problem is with using the 2 versions of office. Please Help... Tammy

  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Disappearing data (2002)

    Sorry, but "disappearing data" is too vague to guess at. You're going to have to provide more details before anyone can possibly suggest a place to start.
    Charlotte

  3. #3
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Re: Disappearing data (2002)

    As Charlotte said, your discription is a little vague. However, there are a few things you might check. You could start by doing a repair/compact your BE database. You might also check your links from the frontend. Are they all pointing to the new location, or do some of them still point to the old location? Is this problem ongoing, or seemingly a one-shot deal; that is, data from a specific date/time is missing, but nothing before or since?
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

  4. #4
    Lounger
    Join Date
    Sep 2002
    Location
    Brookings, South Dakota, USA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Disappearing data (2002)

    Sorry to be vague. This has been happening only since the move and is an ongoing problem where either data from a field is missing or an entire record. I have done the repair/compact on the BE and all the frontends have the correct links. Some of the missing data is old(entered prior to the move) and some new. I actually entered data to a record for a report, ran a query (the data was there), then sorted it diferently and the data in the related table was gone. I entered it again and ran the report cus it was needed asap. I went back later to double check things and the record was missing in the main table and the related table too. This is happening in 2 databases, not related at all. The only other thing I can think of is that I am the only user that was given delete permission on the server so had several copies of the db made when users closed down. This was fixed early on though. Does that bring anything to mind? Thanks, Tammy

  5. #5
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,623
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: Disappearing data (2002)

    Unless you have lots of VBA code in the database, it seems likely that you have some sort of corruption in the back-end database. You might try importing all of the data into a new empty database to see if the problem goes away. But sorting and running simple select queries should not make data go away. Some questions:<UL><LI>What format is your back-end database, 2000 or 2002?<LI>What version of Access are you now running - 2002 or 2003?<LI>Are you working with the data using forms, or are you working at the table level?[/list]I also don't understand why copies of the database were created when other users closed down - the lock file would have been affected, but you shouldn't have been creating copies (unless you compact on close set).
    Wendell

  6. #6
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Re: Disappearing data (2002)

    There is only 1 other thing I can add to what Wendell said. That is, is your server running mirrored drives? If so, you could be having problems there.
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •