Results 1 to 12 of 12
  1. #1
    2 Star Lounger
    Join Date
    Jun 2002
    Location
    vancouver, BC, Br. Columbia
    Posts
    109
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Getting Started (VS.NET Windows XP Pro)

    I have spent a long frustrating day trying to create a first web site with VS.net and Windows XP Pro. I am running IIS 5.1 - I think I am because I can go to http://localhost/localstart.asp in my browser.

    When I try to create a new ASP.NET project with VS at http://localhost/test, I get an error: "The specified web server is not running ASP.NET version 1.1." and when I click OK it returns me to the VS Start page. Any words of help gratefully received.

  2. #2
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    1,862
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Getting Started (VS.NET Windows XP Pro)

    You may want to try downloading the .Net Framework SDK

    That has helped me on several occasions with IIS issues. You should not really to do anything more than install it. If it is going to help, you'll notice it right away. If not, post back and we'll rack our brains for another possibility.

    Also, once you've gotten this installed, be sure that the web folder (or virtual directory) you're attempting to use has been created as an Application:
    - Open IIS, Right-click the desired site, select Properties
    - On the Virtual Directory tab, if the Create button is highlighted click it to create an application (if not, this has already been done)

    Good luck! <img src=/S/thumbup.gif border=0 alt=thumbup width=15 height=15>

  3. #3
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    1,862
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access db not accessible

    Hi Gwenda,

    Hopefully this one will be easy too... It sounds like the anonymous user of your web application does not have permissions to read the MDB file.
    In IIS:
    -Right-click the folder or virtual directory in question, select Properties
    -Select the Directory Security tab
    -Under "Authentication and Access Control" clickt the Edit... button
    -Be sure that "Enable Anonymous Access" is checked
    -Make note of the User name (by default it's the IUSR_<MachineName> account)
    -Make sure that the file/folder in question (with your MDB file) has the proper read and write permissions (depending on what's required by your web application)

    Also, you can enter any user for the Anonymous User - just be sure you type the correct password...

    Hope this helps!

  4. #4
    2 Star Lounger
    Join Date
    Jun 2002
    Location
    vancouver, BC, Br. Columbia
    Posts
    109
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Access db not accessible

    Thanks Mark. In the end, believe it or not, I reformatted my hard drive because I think a lot of my problems came from upgrading to Windows XP Pro AFTER installing .NET. I can now use http://localhost, thankfully.

    But I'm having a problem with Access. I used the Data Form Wizard to test whether my Access database connection is working. The error message I get when I "Build and Browse" is:

    The Microsoft Jet database engine cannot open the file 'Cocuments and SettingsGwendaMy Documentstest1.mdb'. It is already opened exclusively by another user, or you need permission to view its data.

    It is *not* open by another user. I re-booted my machine and tried again just to make sure. The test database is not password protected or anything. I am logged on as Administrator of my workstation. Also, if I try this exact same procedure on another workstation on my network using exactly the same database, it works!
    <img src=/S/bash.gif border=0 alt=bash width=35 height=39> .NET is giving me a headache!

    If you can shed any light on this, I'd be eternally grateful.

  5. #5
    2 Star Lounger
    Join Date
    Jun 2002
    Location
    vancouver, BC, Br. Columbia
    Posts
    109
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access db not accessible

    Hi Mark-voice-in-the-wilderness - I LOVE YOU . Following your advice I started MMC and in IIS I right-clicked on my "Web Sites" folder and went to Directory Security. Anonymous access was on with IUSR_<MachineName> as the user. There was a check box "Allow IIS to control password" which I *unchecked*, and I also deleted the password (which was masked so I don't know what it was).

    And THEN .... <img src=/S/fanfare.gif border=0 alt=fanfare width=31 height=23> It worked! Thank you again a million times. <img src=/S/thankyou.gif border=0 alt=thankyou width=40 height=15>

  6. #6
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    1,862
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access db not accessible

    <img src=/S/blush.gif border=0 alt=blush width=15 height=15> Awwww.......thanks. You're too kind!

    I'm glad it's working <img src=/S/joy.gif border=0 alt=joy width=23 height=23>

  7. #7
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Access db not accessible

    Hi Mark

    I have a problem/question that I think relates to this. I am trying to get started with ASP.NET, and I have bought a book and downloaded the code samples.
    When I put this stuff in a subdirectory of wwwroot the sample files work OK, but when I put them in a virtual directory I can't run any ASP.net code, but I can open plain html files..

    Here is the error I get. It seems to be a problem with permsissions.
    ******************
    Server Error in '/BegASPNet' Application.
    --------------------------------------------------------------------------------

    Access denied to 'Cocuments and SettingsJohnMy DocumentsBegASPNet' directory. Failed to start monitoring directory changes.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: Access denied to 'Cocuments and SettingsJohnMy DocumentsBegASPNet' directory. Failed to start monitoring directory changes.
    ************************

    In IIS I allow Scripts, and in Directory Security I allow Anonymous Access.

    My book tells me to look at the Folder properties in Windows Explorer, and Add the ASPNET user in the Security tab. But when I look at the folder properties, I don't have a Security tab, just General, Sharing,Web Sharing and Customize.

    Do I need to do something to make this Security tab appear, or do I do it somewhere else. (I am running Win XP pro)

    John
    Regards
    John



  8. #8
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    1,862
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access db not accessible

    Hi John,

    Great question!! I remember my early days with ASP.NET - I used to get VERY frustrated with security and setup issues.

    I'll wager that you need to turn off Simple File sharing:
    - Open any Windows Explorer window
    - Tools | Folder Options, select View tab
    - At the very bottom, UNcheck "Use simple file sharing (Recommended)"

    That should make the Security tab visible. (It may require a restart - I can't remember.)

    Once you have the Security tab, make sure to give the Anonymous account the necessary permissions (usually Read & Execute, List Folder Contents, and Read). Depending on your setup, you may also want to give these permissions to the ASPNET account.

    Ohh - also, one thing that still gets me when I start a new project... Be sure to create a Web.config file in the directory. If there is no Web.config, a number of things won't work properly (such as debugging). Although, since you said you've already had the application running, this may not even be an issue for you.

    Post back if that doesn't do the trick! <img src=/S/smile.gif border=0 alt=smile width=15 height=15>

  9. #9
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Access db not accessible

    Thanks Mark

    Your were quite right about needing to turn off Simple File sharing. ( I have also only just upgraded to win XP and haven't had a chance to learn much about it yet.)

    However, my problem is still not solved.

    In IIS i have left the account for anonymous Access at the default which is : IUSR_JOHNLAPTOP (althaough i have tried one or two others) and leave it to IIS to control password.

    In Windows Explorer I have given this account permission to Read and Execute, but i still get the same error as before.

    I also created a web.config file as a empty plain text file. (but when I look in the other foldes where the apps do run, there isn't one.)

    I attach a screen shot of the two permissions.
    Regards
    John



  10. #10
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Access db not accessible

    Mark

    After quite a bit of further experimentation I have got something working that will be OK.

    I had been pointing my virtual directory to Cocuments and SettingsJohnMy DocumentsBegASPNet

    I have now redirected this to: C:aspNet and it works.

    I think everything else is the same. Could it be just the old problem of having spaces in the path perhaps?
    Regards
    John



  11. #11
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    1,862
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access db not accessible

    John,

    Glad you got it working. I don't think spaces in the pathname are a problem. My virtual root folder is D:My DocumentsMy Webs and everything works fine.

    Did you confirm that the ASPNET account also had necessary permissions? That might be the difference.

    Also, I should have been more clear about the Web.config. You'll need more than a blank file. You shoud use Visual Studio to create a new default Web.config for you (Project | Add New Item...). If you don't use Visual Studio, let me know and I'll find a reference to a default Web.config.

    Cheers <img src=/S/cheers.gif border=0 alt=cheers width=30 height=16>

  12. #12
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Access db not accessible

    Thanks Mark

    All works OK when my virutal directory is not inside Cocuments and SettingsJohn . I have tried a couple of other locations. That will do, certainly for now.

    I didn't like my web.config file at all, but for now it is happy without one. I do have visual studio, so I will create them in there when I get to the point of needing them.

    Thanks again for your trouble.

    John
    Regards
    John



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •