Results 1 to 11 of 11
  1. #1
    Lounger
    Join Date
    Jul 2001
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Changing Read-only attribute (XP Home 2002/SP1)

    This one really has me puzzled. Apparently my installation of XP has ceased to allow me to change the read-only attribute on anything in my Shared Documents folder, despite repeated attempts to delete it. I even set the sharing up to allow other users to change the files, but since the RO attr is set for everything, that does no good. Any ideas? I right click on a subfolder or file, click on the RO radio button to change it, click on apply, close the properties window. I then open it again and the RO attr is still set.
    With this situation, I can't copy files to this folder from across the network either.

  2. #2
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Changing Read-only attribute (XP Home 2002/SP1)

    This "Read Only attribute always on" is a normal state of affairs if you look at the properties of a Folder. Do you see this happening for Files as well?

    I suspect your problem copying files across the network may have a different cause.

    StuartR

  3. #3
    Lounger
    Join Date
    Jul 2001
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Changing Read-only attribute (XP Home 2002/SP1)

    It may very well be that the problem lies elsewhere. Files apparently drop the RO attr, but they still produce errors that kill a copy from one machine to another across the network. I've checked my network settings and all of the settings for the shared folder(s), but nothing looks out of line. One computer on the network doesn't show up regularly in My Network Places either. I can find it by Start|Run and entering the address ComputernameSharedFolderName, but I can't account for this behavior, either.

  4. #4
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Changing Read-only attribute (XP Home 2002/SP1)

    To understand the file copy problems we need to know
    <UL><LI>The permissions on the share
    <LI>The permissions on the folder that you are copying to
    <LI>The permissions on any file with the same filename as the one you are copying in
    <LI>What username you are logged in as - on each system[/list]A good place to check some of this information is...
    Right Click my Computer and select Manage
    Expand shared folders in the left hand pane and select shares
    Right click on the share you are using and you can check it's Properties to see the permissions on the share
    Select Sessions in the left hand pain
    This will show you the username that is being used by the remote user

    StuartR

  5. #5
    Lounger
    Join Date
    Jul 2001
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Changing Read-only attribute (XP Home 2002/SP1)

    OK, I've got the Computer Management window open. I'm currently logged on as rshum on the XP box.
    I try to right click on the SharedDocs folder but it shows no Properties option, only Refresh and Help.

    I've mounted the Cocuments and SettingsAll UsersDocuments folder set to share as SharedDocs. It's mounted under Linux as /home/rshum/mnt/Godfrey/SharedDocs and on the linux machine I can browse and look at all the files, but I can't copy to the mounted volume (the SharedDocs folder on the XP box). The user names are identical on both systems.

    In addition, I can ping the Linux box's IP address and get a proper response and I can ping the computer name (Mandrake) and get the same satisfactory response, but My Network Places won't show it and Start|Run and Mandrakehomershum produces a response showing Mandrake is not accessible. The Workgroup name is also identical on both machines (Homenet) but XP doesn't show Mandrake under the workgroup name either.

    The user name shows RSHUM as user and lists the Computer (Mandrake) under the Sessions section. All correct, but access is still blocked.

  6. #6
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Changing Read-only attribute (XP Home 2002/SP1)

    > The user name shows RSHUM as user and lists the Computer (Mandrake) under the Sessions section.

    That's good. This means that the username has been recognised. Just check that it also says "No" in the column headed Guest

    We now need to check the permissions on the share and on the folders.
    In the section titled Shares, right click on the share name, look at the properties, then the permissions, and check that RSHUM has write access to the share. If this is OK then you should check the file and folder permissions.

    The other place to look is in your security event log, which you can access from the same window by selecting Event Viewer > Security in the left hand pane.

    StuartR

    Edited by StuartR to add
    I have just noted that you say there is no Properties on the right click menu for the share. Most strange. You could try using windows explorer to find the shared folder, right click on that and choose "Sharing and Security". Ignore the security tab for now, but look at the Sharing Tab, and click Permissions.

    And I have just noted that you are running XP Home, I have been describing the behaviour of XP Pro, maybe a lounger with XP Home can check that these options are similar since I have never run it.

  7. #7
    Lounger
    Join Date
    Jul 2001
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Changing Read-only attribute (XP Home 2002/SP1

    When I go via Explorer to the Shared Documents folder and right-click and choose Properties, I get a window titled "Shared Documents Properties." There are two tabs - General and Sharing. On the General Tab, the general size, location,etc. are listed and it shows that the Read-only attr is set for the folder.
    On the "Sharing" tab, I have the following boxes checked, "Share this folder on the network" and "Allow network users to change my files". The share name of "SharedDocs" also appears. There is one other section at the top that has a checkbox (currently unchecked) to make this folder private.

  8. #8
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Changing Read-only attribute (XP Home 2002/SP1

    Cotton,

    There is a little piece of <img src=/S/free.gif border=0 alt=free width=30 height=15> ware called "clear read only attributes" ( CROA ) It adds another line to the right click menu to clear RO's in files and sub folders. Don't know if it will do all the things you want to do, but it's worth a try.

    Get it at: CROA

    Bob
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  9. #9
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Changing Read-only attribute (XP Home 2002/SP1

    At this stage I think you will have to hope for a lounger who knows XP Home better than I do.

    I assume that you can copy files to this folder locally and that you can't copy any files to the folder over the share. It might be worth creating a completely new folder and sharing it, just in case there is something odd about this one.

    StuartR

  10. #10
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Changing Read-only attribute (XP Home 2002/SP1

    One other thing to check is whether you have "simple file sharing" enabled. This option hides most of the tabs from users who are too delicate to manage their PCs. Have a look at Windows Explorer, Tools, Folder Options and scroll down to the bolltom of the page to check.

    StuartR

  11. #11
    Lounger
    Join Date
    Jul 2001
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Changing Read-only attribute (XP Home 2002/SP1

    Opened WinExplorer|Tools|Folder Options,but find no reference to "simple file sharing." In dinking around with settings, I am now able to see the Linux box by clicking on Start|Run then typing mandrake and typing Enter. Funny thing, though- it doesn't work with typing "Mandrake" - it seems to require lower case. Now I can copy between the two machines without problems. The Linux box doesn't show up under My Network places, but I can live with that if I can reach it this way. Thanks for all your suggestions.

    Cotton

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •