Results 1 to 8 of 8
  1. #1
    New Lounger
    Join Date
    Jan 2004
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    File association problem (XP)

    I'm having trouble with excel recognizing its own files--I can't open them by double-clicking. I reloaded Office and that helped for a little bit, and then it reverted back to its non-recognition. I've done all the usual steps (includling an external program) in terms of file association, and it doesn't change anything.

    Any suggestions?

  2. #2
    WS Lounge VIP sdckapr's Avatar
    Join Date
    Jul 2002
    Location
    Pittsburgh, Pennsylvania, USA
    Posts
    11,225
    Thanks
    14
    Thanked 342 Times in 335 Posts

    Re: File association problem (XP)

    What is it associated with?
    Windows explorer - Tools - folder options - file types- select XLS files?

    Have you tried:
    right-clicking on an XLS file
    Open with - choose program
    Select MS Excel (make sure you check "Always use this program ..."
    <OK>

    If your associations are getting hijacked, it sounds like a windows issue not an excel issue.

    Steve

  3. #3
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: File association problem (XP)

    In addition to Steve's suggestion, make sure that the "Ignore Other Applications" check box in the General tab of Tools | Options... is NOT checked. If it is, you won't be able to open workbooks from Explorer, although you can still open them from within Excel.

  4. #4
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Dublin, Ireland, Republic of
    Posts
    2,697
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: File association problem (XP)

    Hans,

    I think setting "Ignore Other Applications" on, forces a new instance of Excel rather than using any existing instance that may be running. It should not prevent a workbook opening if double clicked in Explorer.

    Using

    "C:Program FilesMicrosoft OfficeOfficeExcel.exe" /regserver

    (assuming the correct path to the Office folder) should re-establish file associations.

    Andrew

  5. #5
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Dublin, Ireland, Republic of
    Posts
    2,697
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: File association problem (XP)

    Hans, I think XL97 behaved just as XL2000 and later. There may settings independent of XL that have an effect.

    Andrew

  6. #6
    New Lounger
    Join Date
    Jan 2004
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: File association problem (XP)

    First of all, thanks for the suggestions. I had tried the right click approach, but not the ignore other apps box. I'll try that.

    However, the oddest thing just happened--it seemed to have fixed itself for the time being. Really--I'm not trying to waste anyone's time--the file association hijacking has been happening for some time. I rebooted since the last instance of the hijacking, so perhaps that has something to do with it, suggesting an OS problem. Any other suggestions?

    Thanks

  7. #7
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: File association problem (XP)

    Andrew,

    You're correct (was this different in Excel 97?)

    Added later: it does force a new instance of Excel, but this will be empty, the workbook is not opened - at least not on my system.

  8. #8
    3 Star Lounger
    Join Date
    Oct 2004
    Location
    Houston, Texas, USA
    Posts
    242
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: File association problem (XP)

    I searched for a similar issue in the forum and found this thread. Just tried it on one of my users and it worked like a charm. Thank you Hans! You made me a hero to very important person!

    itconc

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •