Results 1 to 7 of 7
  1. #1
    New Lounger
    Join Date
    Mar 2004
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Database Window (XP)

    I have installed XP and kept 2000 on my PC. When the database window the icons for the objects are in no apparent order. The List view is highlighted and when I single click on it the icons are in the expected alphabetic sequence. In addition the Details view empties the window even though it may add scroll bars. Any thoughts?

  2. #2
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,623
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: Database Window (XP)

    I assume you are experiencing different behavior between 2000 and XP - in the Icon view you can move objects around and they remain in that order. However under the Window menu, you can choose Arrange Icons in one of the icon views (small or large) and it doesn't seem to have any effect. In the details view with scroll bars, you should be able to sroll up and to the left and find the objects - I have seen that behavior in XP occasionally in a system with a large number of objects.
    Wendell

  3. #3
    New Lounger
    Join Date
    Mar 2004
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Database Window (XP)

    It is good to know that someone else has seen the problem. You are also correct that the 2K version worked as expected. The only difference is that my detail view only has a side bar and the details are no where to be found even when I go to full screen. Are 70 tables, 50 forms, 75 queries and about 20 others a large number of objects? It is also interesting that the ordering is completely lost when you change the number of objects with a copy, delete or create a new one.

    I guess I can hope that the next service pack fixes the inconvenience. In the mean time I will just click on the view that I want when I need the icons in order and get along without the details. Thanks for the psychological support. Unfortunately, or fortunately I got this software for free from Microsoft and it is the "home use copy" and does not come with free support so they do not even know about this.

  4. #4
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,623
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: Database Window (XP)

    You don't indicate what SP you have installed - but my experience was with SP 2 installed. A SP 3 was released about 10 days ago, but I have not installed it yet - rumor has it that there are some unpleasant issues with security, but that is unconfirmed at this point. The database I was dealing with was somewhat larger (600+ queries) and about 50 modules plus a library database, and it only happened occasionally in the Detail view. I also discovered that if the DB container window was maximized, then the Detail and the List views both worked correctly in my case. You might try doing an Arrange Icons in the detail view and see what happens. It is also possible that you have some mild corruption in your database, so you might try importing everything into a new database and see if things behave better.
    Wendell

  5. #5
    New Lounger
    Join Date
    Mar 2004
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Database Window (2003)

    True confession it has been Access 2003 Version 11.5614.5703 no service packs all along, not XP. Interesting that it is still occurring. I have much simpler data only databases which show the same problem. The problem is not fixed by migrating to a new database.

  6. #6
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,623
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: Database Window (2003)

    I don't see any reports of this kind of problem in the MS KBase for Access 2003 - you might try a repair of your Office installation and see if that improves things. Otherwise I'm stumped - it could be an undocumented bug that would be fixed in a Service Pack.
    Wendell

  7. #7
    New Lounger
    Join Date
    Mar 2004
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Database Window (2003)

    I did a repair. Problem not effected, still there irritating me. I am surprised that I cannot find any references to anything similar at Microsoft either. I suspect it is an install problem effecting the registry or an INI file. I agree that unless someone else sees this here and has an idea I will develop on and await the first service pack.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •