Results 1 to 5 of 5
  1. #1
    2 Star Lounger
    Join Date
    Jan 2004
    Location
    Pontiac, Michigan, USA
    Posts
    170
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Updated Query; Field Not Available for Report (XP)

    I added a field to a query (which is in the table the query is based on). However, I can't seem to be able to access this new query field to add it to the report based on this query. The field doesn't show up at all. What do I need to do?

    Thanks!

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Updated Query; Field Not Available for Report (XP)

    1. Make sure that the Show check box for the new field is ticked.
    2. Make sure that the query has been saved.
    3. If the report was open in design view when you added the field to the query, you must close and reopen it to refresh the field list.

  3. #3
    2 Star Lounger
    Join Date
    Jan 2004
    Location
    Pontiac, Michigan, USA
    Posts
    170
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Updated Query; Field Not Available for Report

    Hans, that didn't seem to do the trick. Do you have any other ideas that might work? It certainly is baffling. When I run the query itself, the field shows up. But when I go into design view in the subreport based on this query, the field is AWOL. Can I manually enter it?

    <img src=/S/confused.gif border=0 alt=confused width=15 height=20> <img src=/S/confused.gif border=0 alt=confused width=15 height=20> <img src=/S/confused.gif border=0 alt=confused width=15 height=20>

    Thanks again for your help.

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Updated Query; Field Not Available for Report

    I can't explain this. What happens if you clear the Record Source property of the subreport, then set it to the correct query name? Can you see the field in the field list then?

  5. #5
    2 Star Lounger
    Join Date
    Jan 2004
    Location
    Pontiac, Michigan, USA
    Posts
    170
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Updated Query; Field Not Available for Report

    That was a good idea. I didn't need to clear the record source. Just clicking on it brought up the SQL part of the query which did NOT have my field in it. Added it and VOILA! everything worked like it should. Don't know why doing it from the query design windown didn't work and this one did. <img src=/S/joy.gif border=0 alt=joy width=23 height=23>

    Thanks for pointing me in the right direction! Have a good week.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •