Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Jan 2004
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Odd custom menus corruption problem (2000 SP3)

    I develop and support a set of Word templates and addins for a firm and occasionally find that custom toolbars become corrupted. What happens is that the entries in one toolbar's menu suddenly get replaced by those from another toolbar's menu. This can happen between two custom toolbars, or as I 've just noticed, between one of mine and Adobe's Acrobat menu appended to the Standard menu.

    I perhaps haven't explained that too well, but if you think of all the File menu items under Format as well as in their normal place, that should give the general idea.

    I have no ideas apart from that it is generally related to high memory usage: many docs or applications being open. Has happened to many users. The problems never seem to cause any stability issues, but once they appear they require all Word windows to be closed and reopened, although they occasionally require a log off and log on again.

    The "imposter" menu items appear to work and dont give any errors.

    Just wondering if anyone has seen this or has any bright ideas.

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Odd custom menus corruption problem (2000 SP3)

    One of my colleagues used some Word add-ins that did something with documents she wrote on her Palm unit. That add-in would occasionally take over a sub-menu of my add-in. No explanation could be found. However, it could be a conflict among the ID numbers of the controls. I believe every control is supposed to have a unique ID number. I'm not sure how Office assigns these numbers when users add their own controls, but if the developers of two add-ins hard-coded the same ID numbers, bad things are likely to happen.

  3. #3
    New Lounger
    Join Date
    Jan 2004
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Odd custom menus corruption problem (2000 SP3)

    Thanks, I'll check out the ID numbers but I'm pretty sure they wouldn't have been set manually. I haven't yet checked whether if you use code to look at the contents of the rogue menu whether you see the "imposter" items or the originals, I'll post up what I find.

  4. #4
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Re: Odd custom menus corruption problem (2000 SP3)

    Elliot,

    Just wondering: are the custom toolbars/menus that are exhibiting this behavior created programatically, or manually (via 'Customize')? I encountered this problem once in Word 2000, and the only possible smoking gun we had was that the menus were created programatically. We got rid of that code and rebuilt the menus manually, and the problem went away - although may have been just coincidence...

    Gary

  5. #5
    New Lounger
    Join Date
    Jan 2004
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Odd custom menus corruption problem (2000 SP3)

    They are definitely created manually.

    Only ever seen on Word 2000 on NT. A minority of users are using the same addins and templates on Word 2002 on Win2k and so far have not reported this issue. We're all migrating soon so I hope that will be the end of it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •