Results 1 to 3 of 3
  1. #1
    4 Star Lounger
    Join Date
    Jan 2002
    Location
    London, Gtr London, England
    Posts
    416
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Missing graphics + VML (WORD 97/2000)

    I have several WORD documents (.doc files) which I save a Web Page (.htm). Word creates sub-folders for the graphics files and copies them into it.

    The problem is that when I view the HTM (double-click it), it opens the HTM file in INTERNET EXPLORER (version 5.0) but doesn't show any graphics. Instead it displays a message to download a Vector Graphic Rendering (VML) component! I don't understand why it needs that since if I open the HTM file for edit under WORD it shows everything correctly. I looked under Options|GeneralWeb Options and tried several different settings (e.g. unchecking 'REly on VML ....' option under Pictures etc). All with no avail. The result is exactly the same.

    Please help me out here. I am in a real fix. Thanks in advance. Don't know where else to go.

    Robie
    Thanks.
    Robie

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Missing graphics + VML (WORD 97/2000)

    A couple of thoughts, based on what I see generated by Word 2002:

    First, open the .htm file in Notepad and copy and paste the raw HTML code into a new, blank Word document.

    Second, delete the reference, if any, to a VML schema in the HTML tag:

    <html xmlns:v="urn:schemas-microsoft-com:vml"
    xmlns="urn:schemas-microsoft-comfficeffice"
    xmlns:w="urn:schemas-microsoft-comffice:word"
    xmlns:dt="uuid:C2F41010-65B3-11d1-A29F-00AA00C14882"
    xmlns="http://www.w3.org/TR/REC-html40">

    Third, delete this block of style definitions:

    <! --[if !mso]>
    <style>
    v:* {behavior:url(#default#VML);}
    o:* {behavior:url(#default#VML);}
    w:* {behavior:url(#default#VML);}
    .shape {behavior:url(#default#VML);}
    </style>
    <![endif]-->

    Fourth, open up the Find and Replace dialog (Edit>Replace), expand the More panel, tick Wildcards, and run these:
    <UL>Find:
    Replace With: leave blank

    That first one should clear a number of extraneous style definitions out of the HEAD section.

    Find:
    Replace With: leave blank

    That second one should remove the code that "prefers" VML over normal image files.

    Find: (<![if !vml]>)(*)(<![endif]>)
    Replace With: 2

    That third one should remove the conditional tags on displaying normal images.[/list]Fifth, copy and paste the remaining code back into Notepad and use Save As to create a new .HTM file. Test in a browser. It seems to work with Word 2002 and Internet Explorer 6. (Probably some of the steps could be skipped, but as we're both in a hurry...)

  3. #3
    4 Star Lounger
    Join Date
    Jan 2002
    Location
    London, Gtr London, England
    Posts
    416
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Missing graphics + VML (WORD 97/2000)

    Thanks. I shall try this out.

    I have feeling it is going to be a looooooooooooooong weekend.

    Thanks once again. I don't understand why WORD adds all that rubbish in there in the first place but there you go. We have got to live with it. <img src=/S/aflame.gif border=0 alt=aflame width=16 height=16>

    For the future projects I think I am going to switch over to Robohelp or something - if the company allows it of course. <img src=/S/crossfingers.gif border=0 alt=crossfingers width=17 height=16>
    Thanks.
    Robie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •