Results 1 to 9 of 9
  1. #1
    New Lounger
    Join Date
    Dec 2000
    Location
    Kent, Kent, England
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    locked by user (access 2000)

    We have a shared db that gave us no problems on WIN98. However, now we are using WIN2000. If my colleague has the db open & I create a new record, as soon as I click on the first field (combo), I get the message "could not update;currently locked by user 'admin' on machine xxxx". Defaul Open mode is set to "shared" but "record locking" is ON.
    HAs anyone an idea why this might be happening please?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: locked by user (access 2000)

    Make sure that "Open databases using record-level locking" is ticked in the Advanced tab of Tools | Options... (while the problem database is open.)

    You may want to turn off record locking for the queries, forms and reports in the database. I usually leave it off in my databases (used by many people daily) and see no problems.

  3. #3
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: locked by user (access 2000)

    I agree with Hans. The RecordLocking setting doesn't do what most people think it does. It simply tells the database engine at what point to apply the lock to the record. It will always lock a record being updated to the table, but it may lock it as soon as a connection to the table is opened (pessimistic), and soon as any add/edit is started (optimistic) or at the point the update (write) occurs (No Locks). I use NoLocks because that causes the fewest potential user collisions.
    Charlotte

  4. #4
    New Lounger
    Join Date
    Dec 2000
    Location
    Kent, Kent, England
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: locked by user (access 2000)

    Thank you both but I have "Open databases using record-level locking" ticked, and the forms have "no locks". On the shortcut properties, we have set Advanced Security to DENY the option to "take ownership", and so far today, we have not had a problem. Hmmm not convinced that this has fixed it, so will monitor.

  5. #5
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: locked by user (access 2000)

    How many fields are there in the table where this collision occurs?
    Charlotte

  6. #6
    Silver Lounger
    Join Date
    Jun 2001
    Location
    Niagara Falls, New York, USA
    Posts
    1,878
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: locked by user (access 2000)

    Hans

    You said:

    <Make sure that "Open databases using record-level locking" is ticked in the Advanced tab of Tools | Options... (while the problem database is open.)>

    Is this done in the be, fe or both?

    John

  7. #7
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: locked by user (access 2000)

    Both, I'd say.

  8. #8
    Silver Lounger
    Join Date
    Jun 2001
    Location
    Niagara Falls, New York, USA
    Posts
    1,878
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: locked by user (access 2000)

    and what about Advanced tab of Tools | Options | Default record locking, how should that be set for 5-10 casual users with very little activity on same records?

    John

  9. #9
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: locked by user (access 2000)

    As Charlotte and I remarked higher up in this thread, set Default record locking to None.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •