Results 1 to 2 of 2
  1. #1
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Spurios parameter prompt (Access 2000)

    I have just had another instance of the occasional problem of a spurious parameter prompt when closing a form.

    In this case if I open the form from two different other forms. In one case it closes ok, the other gives me a spurious parameter prompt on closing.

    If I open the same db using Access 2003, the problem does not occur.

    I have seen similar questions posed in the past, with no really satisfactory solutions given, so I thought i would post the solution I just found in the MSKB.

    Replace

    docmd.close acform, me.name, acSaveNo

    with
    docmd.Echo False
    docmd.close acform, me.name, acSaveNo
    docmd.Echo True

    Problem fixed!
    Regards
    John



  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Spurious parameter prompt (Access 2000)

    Sometimes that spurious parameter prompt comes from a 97 version query migrated to 200x. In previous versions you could leave off the brackets in the parameter or you could use brackets around just one portion of it like this: <code>Forms!MyForm![Whatever]</code>

    When you migrate that query to 2002, for instance, it's liable to misbehave because your parameter is now: <code>[Forms!MyForm![Whatever]]</code>
    Charlotte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •