Results 1 to 7 of 7
  1. #1
    New Lounger
    Join Date
    Jan 2003
    Location
    Rio de Janeiro, Brazil
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Macro warning (MS WORD 2003)

    How to eliminate the "Security Warning" pop-up box about "Wopr_ui.dot containing macros..." whenever Word is started?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Macro warning (MS WORD 2003)

    Try the following:

    Select Tools | Macro | Security...
    Activate the Trusted Sources tab.
    Tick the check box labeled "Trust all installed templates and add-ins".
    Click OK.

  3. #3
    New Lounger
    Join Date
    Dec 2001
    Location
    Albuquerque, New Mexico, USA
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Macro warning (MS WORD 2003)

    Apparently the problem was an easy fix for JLMerino, but I wasn't as lucky.

    Tools | Macro | Security | Trusted Sources | ...
    The check box "Trust all installed templates and add-ins" *is* already checked on my setup with Medium security level, and I still get the Security Warning popup box.

    It's the same WOPR 2003 template (Wopr_ui.dot ) that's triggering the security warning.

    "Security Notes for Microsoft Office Solution Developers" (VBA Help) gives a table showing the Office 2003 responses for various security settings, which suggests to me that the add-in is not digitally signed. (Is this a WOPR issue?)

    What else do I need to do, please?

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Macro warning (MS WORD 2003)

    You might try setting macro security to High (this is the recommendation in the WOPR FAQ).

  5. #5
    New Lounger
    Join Date
    Dec 2001
    Location
    Albuquerque, New Mexico, USA
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Macro warning (MS WORD 2003)

    Thank you for reminding me to look at the FAQ! I see that now, but trying to reset the macro security level led to the next problem: it won't change to anything but "medium."??

    I can select any of the four radio buttons, click OK, and then return to the same dialog box and find macro security still set to "medium."

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Macro warning (MS WORD 2003)

    Are you on a corporate network? If so, the network administrator may have disabled changing the security level. If not, you may need to have administrator rights on your PC.

  7. #7
    New Lounger
    Join Date
    Dec 2001
    Location
    Albuquerque, New Mexico, USA
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Macro warning (MS WORD 2003)

    Thank you! That seems to have been the problem. (Sorry for my delayed response to the post; it's taken all this time to sort it out).

    The fix was to set Word's macro security level manually with the registry editor: Navigate to the key:
    HKEY_LOCAL_MACHINESOFTWAREMicrosoftOffice11.0WordS ecurity
    and manually modify the value of "Level" ... "3" sets macro security to "high". Medium ("2") is how it had been set before.

    Now I see the same behavior as before (Word ignores any attempt to change the macro security level from within the program), but at least WOPR now loads without having to click through two levels of dialog box warnings.

    Thanks, George

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •