Results 1 to 4 of 4
  1. #1
    4 Star Lounger
    Join Date
    Feb 2001
    Location
    Gillingham, Kent, England
    Posts
    511
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Automation Server Error

    I have created a VB6 application using SQL Server as the database.After making an EXE I tried installing the application on another machine on the network. When I tried running it I got the following error:
    'Class doesn't support Automation or does not support expected interface.'
    The application seems to load OK visually but I get no data populating the application.
    Any ideas on how to solve it??

    Thanks

  2. #2
    Gold Lounger
    Join Date
    Dec 2000
    Location
    Hollywood (sorta), California, USA
    Posts
    2,759
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Automation Server Error

    What data access technology are you using?

    Sounds like you have it and the user does not.
    Kevin <IMG SRC=http://www.wopr.com/w3tuserpics/Kevin_sig.gif alt="Keep the change, ya filthy animal...">
    <img src=/w3timages/blackline.gif width=33% height=2><img src=/w3timages/redline.gif width=33% height=2><img src=/w3timages/blackline.gif width=33% height=2>

  3. #3
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Automation Server Error

    Does the target machine have SQL Server, MSDE or Office 2000 installed? Did you remember to include the database file itself in your setup? Is the target machine running VB5? There's a bunch of things that could have gone wrong here, and this just scratches the surface.
    Charlotte

  4. #4
    4 Star Lounger
    Join Date
    Feb 2001
    Location
    Gillingham, Kent, England
    Posts
    511
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Automation Server Error

    Thanks for replying to this question. However, the problem is now being looked into by somebody else. I will leave the post here for now and if the problem gets fixed, i'll find out how and post it for anybody else getting the same error.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •