Results 1 to 5 of 5
  1. #1
    Super Moderator WebGenii's Avatar
    Join Date
    Jan 2001
    Location
    Redcliff, Alberta, Canada
    Posts
    4,066
    Thanks
    2
    Thanked 5 Times in 5 Posts

    Erratic Behaviour (Access 2002/SP3)

    I'm running into problems with this line in the code attached to a form.
    DoCmd.SendObject acReport, stDocName1, acFormatRTF, strAllToEmail, , , strSubject, strMessage, True
    The problem is that it is not opening up the mail message (or even sending it at all).
    I couldn't find any errors within the form that would prevent this from working, and indeed I get a little message saying that Access is emailing my report - but no joy.
    I ended up rebuilding the form from scratch, which seemed to take care of the problem on my laptop. Today, I'm checking on my desktop and boom - it is back to where it was.
    Both machines have the same references set.

    Does anyone have a suggestion?
    [b]Catharine Richardson (WebGenii)
    WebGenii Home Page
    Moderator: Spreadsheets, Other MS Apps, Presentation Apps, Visual Basic for Apps, Windows Mobile

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Erratic Behaviour (Access 2002/SP3)

    Does it make a difference if your mail application is open or not when you try this?

    Also, check for security warnings that don't get the focus, they might be lurking behind the Access application window.

  3. #3
    Super Moderator WebGenii's Avatar
    Join Date
    Jan 2001
    Location
    Redcliff, Alberta, Canada
    Posts
    4,066
    Thanks
    2
    Thanked 5 Times in 5 Posts

    Re: Erratic Behaviour (Access 2002/SP3)

    No, it doesn't matter if my mail is open or closed. I find no security messages. Other forms that are launching email messages are working just fine... <img src=/S/dizzy.gif border=0 alt=dizzy width=15 height=15>
    [b]Catharine Richardson (WebGenii)
    WebGenii Home Page
    Moderator: Spreadsheets, Other MS Apps, Presentation Apps, Visual Basic for Apps, Windows Mobile

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Erratic Behaviour (Access 2002/SP3)

    Troubleshooting can take a lot of time. Start by making a backup copy of the database, just in case. You might try modifying the various arguments to SendObject to see if you can find one that causes problems. For example: replace strAllToEmail by a quoted string such as "LoungeAdmin@wopr.com".

  5. #5
    Super Moderator WebGenii's Avatar
    Join Date
    Jan 2001
    Location
    Redcliff, Alberta, Canada
    Posts
    4,066
    Thanks
    2
    Thanked 5 Times in 5 Posts

    Re: Erratic Behaviour (Access 2002/SP3)

    I think, in fact that the strAllToEmail variable is the problem - because when I remove it the message is generated.
    Both my laptop and desktop use Outlook - however the laptop is connected to a corporate email, while the desktop connects to my ISP.
    It appears to be a difference in the way they interpret email addresses (grrrr).

    More error checking appears to be in order.

    Thanks
    [b]Catharine Richardson (WebGenii)
    WebGenii Home Page
    Moderator: Spreadsheets, Other MS Apps, Presentation Apps, Visual Basic for Apps, Windows Mobile

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •