Results 1 to 6 of 6
  1. #1
    Lounger
    Join Date
    Mar 2004
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts

    form fields and quotation marks (Word 2002)

    I have created a document with form fields, but when the user fills them in, they cannot put in quotation marks or apostrophes. The keys just don't put anything in. On the other hand, I am able to copy and paste a quotation mark into the field, but this is a very clunky work around. Any thoughts? Thanks guys.
    Arlene

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: form fields and quotation marks (Word 2002)

    Seems to work fine for me. Is there any possibility that those keys are customized to run a macro to do something else by one of your users' templates? One test you can to is as follows: disable "everything" that has been added to the user's environment by starting Word in "factory new" mode. Use Start > Run... type winword.exe /a and press Enter. Then open your form and see if the problem persists.

    (And there always is the Alt+number pad workaround. Alt+0034 for a quotation mark, Alt+0039 for an apostrophe.)

  3. #3
    4 Star Lounger
    Join Date
    Dec 2003
    Location
    Zoetermeer, Zuid-Holland, Netherlands
    Posts
    559
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: form fields and quotation marks (Word 2002)

    Maybe your users use the US International keyboard setting in Windows (control panel)?
    In that case quotation marks and apostrophs are "dead keys", waiting for another key, to produce a special character.
    Example: [ ' ][ e ] results in

  4. #4
    Lounger
    Join Date
    Mar 2004
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: form fields and quotation marks (Word 2002)

    This worked for me, too. Now back to the drawing board, to weed through all of the very old bad code. I think I wrote something in 1993 to turn on curly quotes.

    Here's another one that's got me baffled, if you don't mind. The user fills in the form (text). I then unlink the fields. When I run a spell check, it all checks out as OK even though there are obvious errors. I tried adding the following:
    Application.ResetIgnoreAll
    ActiveDocument.SpellingChecked = False
    ActiveDocument.CheckSpelling
    That works great with text I have simply typed, but not in the document created from the formfields. I can't reset it. The only way I have figured out to spell check it is to copy the whole document to clipboard, paste it into notebook, copy it back from there, then paste it into word in a new document. Even a paste without the notebook step won't do. This is true even in the factory fresh /a word.

  5. #5
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: form fields and quotation marks (Word 2002)

    You can unlink FormFields? I didn't even realize that. I know that some regular fields, such as DATE, are marked with No Proofing (the setting you can set using a checkbox under Tools>Language). Could this also extend to FormFields? If so, you could select all and globally clear the No Proofing attribute.

  6. #6
    Lounger
    Join Date
    Mar 2004
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: form fields and quotation marks (Word 2002)

    I am so tickled that I taught you something!! Of course, you probably have no need to unlink those fields, but yes, you can unlink them, and then treat them as native text. I have a situation in which I use the form fields, create a document that uses the info in 2 different ways, the second with a ref field. Then I unlink them, split them at a book mark, and voila, no typing twice. Works great except for that spell check thing, which you completely fixed. Indeed, my answer was in Languages, where I had never looked. Selected the whole document, then check the check box 2x to clear it, then all was well. Thanks again to all you loungers!

    Arlene

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •