Results 1 to 5 of 5
  1. #1
    Lounger
    Join Date
    Feb 2002
    Location
    Summerville, South Carolina, USA
    Posts
    28
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Relationship question (Access 2K)

    I've inherited the start of an application that I've been requested to re-design it similar to an application that I've been using for years. In both the old and inherited application, I have it set up so that all the forms, queries, reports, etc. in an APP.MDB and the data only in a DATA.MDB. APP.MDB is linked to the tables in DATA.MDB. In my old application when I set up the queries the one-to-many lines would automatically be inserted and show a 1 on the one side and the infinity sign on the many side. In this new application when I set up a query, I just get the straight lines between the common fields, the Edit relationship shows it to be a one-to-many, but it does not have the "1" on the one side and the Infinity sign on the many side. Even the relationship set up as laid out in Tools>Relationships... just shows the straight lines. When I go back to look at the relationship in the data database (DATA.MDB), the 1 and infinity indications are there.

    Is there a reason why they are not showing up in the application side (front end)?

    Hope I've made myself clear.

    Thanks,
    Bill Blazer

  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Relationship question (Access 2K)

    You're seeing those in the back end that way because of referential integrity between the back end tables. You can only enforce RI between tables within the same database, and the relationship carries forward to the front end, although the appearance is not the same. This is just the way Access works. You can't change the referential integrity on linked tables from the front end anyhow, and I suspect that display difference is a reflection of that distinction.
    Charlotte

  3. #3
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Relationship question (Access 2K)

    I see the ones and the infinity symbols when I look at the relationships diagram in the front end of a db, where referential integrity is set in the backend.

    This is true in both 2000 and 2003, I have just looked at a few .
    Regards
    John



  4. #4
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Re: Relationship question (Access 2K)

    In the backend, I'd delete the relationship between 2 tables (where RI is enforced), then restablish the link. Then go to the frontend and see if a new query will show the symbols. You might also want to try deleting both tables from the frontend, then relinking to these tables.

    If this works, do it with all the relationships.
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

  5. #5
    Lounger
    Join Date
    Feb 2002
    Location
    Summerville, South Carolina, USA
    Posts
    28
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Relationship question (Access 2K)

    Mark, tried what you suggested and it is not carrying through, but like I said in my old application is carrying through as Charlotte suggested. Just was wondering why I didn't see the symbols I was used to seeing in my old application and not this one eventhough the setup is almost identical (Client/Client contacts type tables). Regardless, the data is being presented properly and that is what really matters, I guess.

    Thanks to all.

    Bill Blazer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •