Results 1 to 5 of 5
  1. #1
    5 Star Lounger
    Join Date
    Jun 2001
    Location
    USA
    Posts
    708
    Thanks
    48
    Thanked 1 Time in 1 Post

    SmartHeap MEM_BAD_POINTER error (XP SP2)

    Hi, After recently installing SP2 on XP Home, I now receive the following error message (which follows a scheduled run of Backup MyPC):

    Title bar: SmartHeap
    Message: MEM_BAD_POINTER error

    The buttons are OK and Cancel.

    http://www.microquill.com/kb/xpsp2.htm summarizes the situation well, but says Microsoft has yet to release a patch.

    Has this problem happened to anybody else? Does anybody have any additional info? Thanks.

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,594
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: SmartHeap MEM_BAD_POINTER error (XP SP2)

    Have you tried any of the solutions other than removing SP-2? Have you contacted Backup MyPC support?

    Joe
    Joe

  3. #3
    5 Star Lounger
    Join Date
    Jun 2001
    Location
    USA
    Posts
    708
    Thanks
    48
    Thanked 1 Time in 1 Post

    Re: SmartHeap MEM_BAD_POINTER error (XP SP2)

    <P ID="edit" class=small>(Edited by Jon_Rick on 06-Sep-04 00:45. StompSoft's reply was a simple copy and paste of the Web page I referred to in my initial post.)</P>Joe,

    Thanks for your reply.

    I'm relucant to remove SP2, since it seems to offer so many improvements.

    Are there any other solutions, as you insinuate?

    I'm awaiting a reply from StompSoft, the maker of Backup MyPC.

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,594
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: SmartHeap MEM_BAD_POINTER error (XP SP2)

    It appears from the link you posted that you had to have enabled right-to-left or East Asian languages. Do you really need this? Can you selectively uninstall and re-install as needed?

    Joe
    Joe

  5. #5
    5 Star Lounger
    Join Date
    Jun 2001
    Location
    USA
    Posts
    708
    Thanks
    48
    Thanked 1 Time in 1 Post

    Re: SmartHeap MEM_BAD_POINTER error (XP SP2)

    I went to the Control Panel | Regional and Language Options | Languages tab, and unchecked "Install files for comples script and right-to-left languages (including Thai)." "Install files for East Asian languages" was not checked.

    I don't expect the error to disappear, but I'll let you know if it does. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •