Results 1 to 8 of 8
  1. #1
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Sacramento, California, USA
    Posts
    491
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Datasheet issue (WINXP - ACC 97)

    My cubicle neighbor has the same computer & OS that I do, and we are both on the same network.

    We have a small attendance database on the network (FE/BE) and both have a shortcut to this db.
    There is a select query that works fine on my computer, but on hers, the fields are all blank except for the
    employee's name. There is definitely data that should populate these fields - it works perfectly on my
    computer, but not hers. I even tried to run the query by not using her shortcut, but directly from the FE,
    and it still didn't show data other than the name. I imported everything into a new database, I refreshed the links
    and it still didn't work. I tried it from several other PCs, and it worked fine.

    What should I be looking for?

    Thank you very much.

    Michael Abrams

  2. #2
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Datasheet issue (WINXP - ACC 97)

    Does the query involve calculated fields that use Access functions like Left, Right, InStr ?

    They can fail if there are errors in the References.

    To check References open any code windows, and go to tools...references and look for the word Missing next to any.
    Regards
    John



  3. #3
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Sacramento, California, USA
    Posts
    491
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Datasheet issue (WINXP - ACC 97)

    I'm at home now, so I will check the query tomorrow.
    All other queries, as a matter of fact, all other databases on her machine work fine (so it seems so far !)
    I will check the references tomorrow - if that isn't it, I will post the code.
    As usual, I just never understand how it works fine on one machine and not the next, but
    hopefully we can figure this out !

    I appreciate your input Mr. Hutchinson.

    Michael Abrams

  4. #4
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Datasheet issue (WINXP - ACC 97)

    Just one more test for tomorrow : If you open the tables directly, can you see the data ?
    Francois

  5. #5
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Datasheet issue (WINXP - ACC 97)

    And another : Have you try to recreate the query from scratch ?
    Francois

  6. #6
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Sacramento, California, USA
    Posts
    491
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Datasheet issue (WINXP - ACC 97)

    <hr>If you open the tables directly, can you see the data ?<hr>
    Yes !! That is what is crazy - I am using the same front end from my machine and then from her machine.
    So it isn't even like I am trying this with 2 separate front ends !!! I am using the same front end !!

    <hr>Have you try to recreate the query from scratch ?<hr>
    No - I imported everything into a fresh db, but tomorrow I will recreate the query.

    For some reason, I believe it is a setting on her PC that I can't figure out.
    I even looked to see that her datasheet options were exactly the same as mine.

    Well, I will have to wait another 13 hours to check it out. Please stay tuned !!

    Michael Abrams

  7. #7
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Datasheet issue (WINXP - ACC 97)

    Do you have the same Jet service pack on both machines? I've seen very weird behavior on a network when one machine couldn't see data but another could. Turned out the one that couldn't see it didn't have the latest Jet 3.5 service pack.
    Charlotte

  8. #8
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Sacramento, California, USA
    Posts
    491
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Datasheet issue (WINXP - ACC 97)

    Hi Charlotte !

    You know what? That sounds like a VERY good possibility.
    Our IT people kinda do the updates a little here and a little there.

    I will check it in the morning.

    Thank you for your reply !!

    Michael Abrams

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •