Results 1 to 9 of 9

Thread: Access denied

  1. #1
    Star Lounger
    Join Date
    Jan 2001
    Location
    Yorkshire, England
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Access denied

    problem has come up on our NT pdc. When I attach to a share on it and view user logon scripts I can list/open them all fine, but as soon as I try to edit, delete or create a new one I get "access denied". Viewing effective permissions on any file or folder I am God - I have all permissions available, but I can still do nothing.
    If I log on locally to the PDC with the same user account everything works fine. As far as I can see no permissions have been changed recently.

    I've checked share & NTFS permissions but all looks OK. I usually attach to the C$ share but have tried attaching to NETLOGON or WINNT and it makes no differance. Remote I can view only, locally I can do anything.

    Anybody got any clues, ideas, strong drink?

    thanks

  2. #2
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Quedgeley, Gloucester, England
    Posts
    5,333
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Access denied

    Bryan

    Have you tried linking to REPL$ or to NETLOGON? Or using one of your service accounts which have Domain Admins rights?

    I must say that I suspect that we have this too, but since a program (well, actually, to your surprise it's a BATch file!) writes out the Logon Script files to the Export Directory, I've never really bothered looking at it.

    John
    <font face="Script MT Bold"><font color=blue><big><big>John</big></big></font color=blue></font face=script>

    Ita, esto, quidcumque...

  3. #3
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,594
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: Access denied

    What workstation OS? Are you sure you're logged into the domain and not locally on the workstation?

    Joe
    Joe

  4. #4
    Star Lounger
    Join Date
    Jan 2001
    Location
    Yorkshire, England
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access denied

    John, Joe

    thanks for your replies

    My workstaion is XP pro and I'm logging on to the domain OK. I can make changes on other servers including BDCs no prob, it's just the PDC thats being snarky.

    I've tried attaching to C$, WINNT, REPL$, NETLOGON and makes no odds, remote I just can't do a damn thing, locally all is as it should be. My own account is a domain admin but have tried attaching share under other DA accounts and no change.

    Rapidly moving to the strong drink and sledgehammer option

    any thoughts more than welcome

    Thanks

  5. #5
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Quedgeley, Gloucester, England
    Posts
    5,333
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Access denied

    Bryan

    It won't be any consolation to you but on my XP Pro box I've just NET USEd to our PDC's REPL$, changed to that drive and CDed to SCRIPTS, and edited one of the Logon Script files and SAVEd it. No problems...

    Have you got an NT workstation you can try it from?

    John
    <font face="Script MT Bold"><font color=blue><big><big>John</big></big></font color=blue></font face=script>

    Ita, esto, quidcumque...

  6. #6
    Star Lounger
    Join Date
    Jan 2001
    Location
    Yorkshire, England
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access denied

    John

    you're right about it being no consolation <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

    that is exactly what I could do Monday PM but haven't been able to do since Tuesday AM.

    Just about accepted that a rebuild may be the only way forward - give me something to do other that what I'm doing now <img src=/S/brickwall.gif border=0 alt=brickwall width=25 height=15> - <img src=/S/hairout.gif border=0 alt=hairout width=31 height=23>

    Anyhow that will have to wait till Monday at least so any thoughts before then gratefully received

    thanks

  7. #7
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,594
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: Access denied

    Bryan,

    What changed on the workstation and the server?

    Joe
    Joe

  8. #8
    Star Lounger
    Join Date
    Jan 2001
    Location
    Yorkshire, England
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access denied

    Joe

    what's changed ? absolutely nothing !! or at least nothing I've been able to track down. Everything looks just as it should, it's just it don't work. Permissions look fine whether I view them from the workstation or on the server

    got to admit this has me totally stumped

  9. #9
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Access denied

    Have you checked the SHARE permissions as well as the FILE and FOLDER permissions?
    Have you checked (Computer Management > Shared Folders > Sessions) on the server to ensure you are logged in as the username you think you are?

    StuartR


    PS I just realised we are talking NT here, I can't remember the equivalent command to check the username of a remote session on NT, Sorry.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •