Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Oct 2002
    Location
    Carol Stream, Illinois, USA
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Merge 'don't show empty field' problem (Word XP (SP2))

    Trying to make a catalog from Excel using a mail merge, and this is the first time using Word XP. In Word 2000, in the Mail Merge Helper, there was a place to select something like "Don't show empty fields", but I haven't found anything similar in XP. The result is that when I have fields that are blank in the Excel file, they show up in the merged file as zeros, when I'd just like them to be ignored.

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Merge 'don't show empty field' problem (Word XP (SP2))

    The way mailmerge works in Word 2002 (XP) is quite different from previous versions. Suppressing blank records is on by default, but the new standard method of connecting to the data source (OLE DB) has lots of problems. One of them is that blank cells in Excel are interpreted as zeros. To get around this:
    - Select Tools | Options... (in Word)
    - Activate the General tab.
    - Tick the "Confirm conversion at Open" check box.
    - Click OK.
    - When you select the Excel workbook in step 3 of the mail merge task pane, you will be prompted how to connect to the workbook. Select DDE or Conversion, not OLE DB or ODBC.
    - Blank cells will now be treated correctly, so that blank records are suppressed.

  3. #3
    New Lounger
    Join Date
    Oct 2002
    Location
    Carol Stream, Illinois, USA
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Merge 'don't show empty field' problem (Word XP (SP2))

    That did it - thanks a ton!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •